summaryrefslogtreecommitdiffstats
path: root/lib/interfaces/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit114a878c64ce6f8223cfd22d76a20eb16d177e5e (patch)
treeacaf47eb0fa12142d3896416a69e74cbf5a72242 /lib/interfaces/Makefile.am
downloadtdevelop-114a878c64ce6f8223cfd22d76a20eb16d177e5e.tar.gz
tdevelop-114a878c64ce6f8223cfd22d76a20eb16d177e5e.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdevelop@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'lib/interfaces/Makefile.am')
-rw-r--r--lib/interfaces/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/lib/interfaces/Makefile.am b/lib/interfaces/Makefile.am
new file mode 100644
index 00000000..6b171b10
--- /dev/null
+++ b/lib/interfaces/Makefile.am
@@ -0,0 +1,40 @@
+INCLUDES = -I$(top_srcdir)/lib/interfaces/external -I$(top_srcdir)/lib/util -I$(top_srcdir)/lib/cppparser \
+ $(all_includes)
+
+noinst_LTLIBRARIES = libkdevinterfaces.la
+
+libkdevinterfaces_la_SOURCES = kdevcore.cpp kdevproject.cpp \
+ kdevlanguagesupport.cpp kdevpartcontroller.cpp kdevapi.cpp KDevCoreIface.skel \
+ kdevmainwindow.cpp KDevPartControllerIface.skel kdevplugin.cpp kdevcoderepository.cpp \
+ codemodel.cpp codemodel_treeparser.cpp codemodel_utils.cpp \
+ kdevdesignerintegration.cpp kdevplugincontroller.cpp kdevplugininfo.cpp KDevCoreIface.cpp \
+ KDevPartControllerIface.cpp katedocumentmanagerinterface.cpp katedocumentmanagerinterface.skel \
+ kdevprojectiface.cpp kdevprojectiface.skel kdevdesignerintegrationiface.cpp \
+ kdevdesignerintegrationiface.skel hashedstring.cpp
+libkdevinterfaces_la_LDFLAGS = -no-undefined $(all_libraries)
+libkdevinterfaces_la_LIBADD = $(top_builddir)/lib/interfaces/external/libkinterfacedesigner.la \
+ $(top_builddir)/lib/util/libkdevutil.la \
+ $(LIB_KDEUI) $(LIB_KHTML) $(LIB_KPARTS) -lktexteditor -lkscript -lDCOP
+
+kdevelopincludedir = $(includedir)/kdevelop/interfaces
+kdevelopinclude_HEADERS = kdevlanguagesupport.h kdevmainwindow.h \
+ kdevpartcontroller.h kdevplugin.h kdevproject.h kdevcore.h kdevcoderepository.h codemodel.h \
+ codemodel_utils.h codemodel_treeparser.h kdevgenericfactory.h kdevapi.h \
+ kdevdesignerintegration.h kdevplugincontroller.h kdevplugininfo.h KDevCoreIface.h \
+ KDevPartControllerIface.h katedocumentmanagerinterface.h \
+ hashedstring.h
+
+
+servicetypedir = $(kde_servicetypesdir)
+servicetype_DATA = kdevelopproject.desktop kdeveloplanguagesupport.desktop \
+ kdevelopplugin.desktop
+
+METASOURCES = AUTO
+
+SUBDIRS = extensions external extras
+
+DOXYGEN_REFERENCES = dcop interfaces kdecore kdefx kdeui khtml kmdi kio kjs kparts kutils kdevutil designer_integration kdevcatalog kdevprofileslib kdevextensions
+DOXYGEN_PROJECTNAME = KDevelop Interfaces Library
+DOXYGEN_DOCDIRPREFIX = kdev
+include ../../Doxyfile.am
+noinst_HEADERS = kdevprojectiface.h kdevdesignerintegrationiface.h