summaryrefslogtreecommitdiffstats
path: root/parts/grepview/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-29 22:43:34 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-30 16:00:07 +0200
commitfe44776673b28ca94338f23d8e7ac71593fa88ba (patch)
treeb900146c853acbd44900bfb77a35a1af3c77aa5d /parts/grepview/CMakeLists.txt
parentc0b663c4c873df495743600b8f703744420eddfa (diff)
downloadtdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.tar.gz
tdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'parts/grepview/CMakeLists.txt')
-rw-r--r--parts/grepview/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/parts/grepview/CMakeLists.txt b/parts/grepview/CMakeLists.txt
index 5ad23e4f..a6b6ed6f 100644
--- a/parts/grepview/CMakeLists.txt
+++ b/parts/grepview/CMakeLists.txt
@@ -27,7 +27,12 @@ link_directories(
##### other data ################################
-install( FILES kdevgrepview.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kdevgrepview.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR tdevelop-desktops
+)
+
install( FILES kdevgrepview.rc DESTINATION ${DATA_INSTALL_DIR}/kdevgrepview )