summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-16 13:53:18 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-16 13:53:18 -0600
commit2ecab1a194b0dc551b478820e1aaa3b8713354cc (patch)
treeae4df71ed26f3dc2dd605970d8d455165a1c8ab3 /src/Makefile.am
parent549fec618f0b15c9316fc0a5ebe93c2829bc0b1b (diff)
downloadtdevelop-2ecab1a194b0dc551b478820e1aaa3b8713354cc.tar.gz
tdevelop-2ecab1a194b0dc551b478820e1aaa3b8713354cc.zip
Additional renaming of kde to tde
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am28
1 files changed, 14 insertions, 14 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e88cddfe..701fcbb1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,9 +7,9 @@ INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/lib/interfaces \
KDE_OPTIONS=nofinal
lib_LTLIBRARIES = libkdevshell.la
-libkdevshell_la_LDFLAGS = $(all_libraries) -lkdevelop -L../lib/.libs -L../lib/interfaces/external/.libs -lkinterfacedesigner
+libkdevshell_la_LDFLAGS = $(all_libraries) -ltdevelop -L../lib/.libs -L../lib/interfaces/external/.libs -lkinterfacedesigner
libkdevshell_la_LIBADD = \
- $(top_builddir)/src/profileengine/lib/libprofileengine.la $(top_builddir)/lib/libkdevelop.la \
+ $(top_builddir)/src/profileengine/lib/libprofileengine.la $(top_builddir)/lib/libtdevelop.la \
$(top_builddir)/lib/widgets/libkdevwidgets.la $(top_builddir)/lib/interfaces/extras/libkdevextras.la \
$(top_builddir)/src/newui/libd.la $(LIB_KHTML) -lktexteditor -L../lib/interfaces/external/.libs -lkinterfacedesigner
libkdevshell_la_SOURCES = api.cpp core.cpp documentationpart.cpp \
@@ -19,29 +19,29 @@ libkdevshell_la_SOURCES = api.cpp core.cpp documentationpart.cpp \
projectmanager.cpp projectsession.cpp shellextension.cpp simplemainwindow.cpp \
splashscreen.cpp statusbar.cpp toplevel.cpp
-bin_PROGRAMS = kdevelop kdevassistant
+bin_PROGRAMS = tdevelop kdevassistant
-kdevelop_SOURCES = main.cpp kdevideextension.cpp settingswidget.ui
+tdevelop_SOURCES = main.cpp kdevideextension.cpp settingswidget.ui
-kdevelop_METASOURCES = AUTO
-kdevelop_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -lktexteditor -lkdevelop -L../lib/.libs -L../lib/interfaces/external/.libs -lkinterfacedesigner
-kdevelop_LDADD = libkdevshell.la -L../lib/interfaces/external/.libs -lkinterfacedesigner
+tdevelop_METASOURCES = AUTO
+tdevelop_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -lktexteditor -ltdevelop -L../lib/.libs -L../lib/interfaces/external/.libs -lkinterfacedesigner
+tdevelop_LDADD = libkdevshell.la -L../lib/interfaces/external/.libs -lkinterfacedesigner
-rcdir = $(kde_datadir)/kdevelop
-rc_DATA = kdevelopui.rc eventsrc
+rcdir = $(kde_datadir)/tdevelop
+rc_DATA = tdevelopui.rc eventsrc
# default KDevelop configuration
-kdevelopdatadir = $(kde_confdir)
-kdevelopdata_DATA = kdeveloprc kdevassistantrc
+tdevelopdatadir = $(kde_confdir)
+tdevelopdata_DATA = tdeveloprc kdevassistantrc
SUBDIRS = profiles profileengine newui kconf_update
-kdevassistant_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -lktexteditor -lkdevelop -L../lib/.libs -L../lib/interfaces/external/.libs -lkinterfacedesigner
+kdevassistant_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -lktexteditor -ltdevelop -L../lib/.libs -L../lib/interfaces/external/.libs -lkinterfacedesigner
kdevassistant_SOURCES = main_assistant.cpp kdevassistantextension.cpp
kdevassistant_LDADD = libkdevshell.la -L../lib/interfaces/external/.libs -lkinterfacedesigner
rc_assistantdir = $(kde_datadir)/kdevassistant
rc_assistant_DATA = kdevassistantui.rc
-shellincludedir = $(includedir)/kdevelop/shell
+shellincludedir = $(includedir)/tdevelop/shell
shellinclude_HEADERS = api.h core.h documentationpart.h editorproxy.h \
generalinfowidget.h languageselectwidget.h mainwindowshare.h partcontroller.h \
plugincontroller.h projectmanager.h projectsession.h shellextension.h splashscreen.h \
@@ -52,6 +52,6 @@ DOXYGEN_REFERENCES = dcop interfaces tdecore tdefx tdeui khtml kmdi kio kjs kpar
DOXYGEN_PROJECTNAME = KDevelop Generic Shell
DOXYGEN_DOCDIRPREFIX = kdevshell
include ../Doxyfile.am
-profilesdatadir = $(kde_datadir)/kdevelop/profiles
+profilesdatadir = $(kde_datadir)/tdevelop/profiles
profilesdata_DATA = projectprofiles