summaryrefslogtreecommitdiffstats
path: root/kdevdesigner/shared/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kdevdesigner/shared/CMakeLists.txt')
-rw-r--r--kdevdesigner/shared/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/kdevdesigner/shared/CMakeLists.txt b/kdevdesigner/shared/CMakeLists.txt
new file mode 100644
index 00000000..46c5e8f6
--- /dev/null
+++ b/kdevdesigner/shared/CMakeLists.txt
@@ -0,0 +1,26 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/interfaces/external
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### shared (static) ########################
+
+tde_add_library( shared STATIC_PIC
+ SOURCES
+ domtool.cpp parser.cpp ui2uib.cpp uib.cpp
+ widgetdatabase.cpp
+)