summaryrefslogtreecommitdiffstats
path: root/lib/cppparser/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/cppparser/Makefile.am')
-rw-r--r--lib/cppparser/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/lib/cppparser/Makefile.am b/lib/cppparser/Makefile.am
new file mode 100644
index 00000000..1ee03ce7
--- /dev/null
+++ b/lib/cppparser/Makefile.am
@@ -0,0 +1,11 @@
+INCLUDES = -I$(top_srcdir)/lib/interfaces $(all_includes)
+AM_CXXFLAGS = -DKDEVELOP_BGPARSER
+lib_LTLIBRARIES = libkdevcppparser.la
+libkdevcppparser_la_LDFLAGS = $(all_libraries)
+libkdevcppparser_la_LIBADD = $(LIB_QT) $(LIB_KDECORE) $(top_builddir)/lib/interfaces/libkdevinterfaces.la -lDCOP $(LIB_KDEUI) $(LIB_KPARTS) -lktexteditor $(LIB_KIO) -lkscript
+libkdevcppparser_la_SOURCES = ast.cpp cachemanager.cpp driver.cpp errors.cpp \
+ lexer.cpp lexercache.cpp lookup.cpp parser.cpp tree_parser.cpp
+
+kdevcppparserincludedir = $(includedir)/kdevelop/cppparser
+kdevcppparserinclude_HEADERS = ast.h driver.h lexer.h parser.h tree_parser.h errors.h lookup.h cachemanager.h lexercache.h macro.h
+