summaryrefslogtreecommitdiffstats
path: root/parts/filter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'parts/filter/Makefile.am')
-rw-r--r--parts/filter/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/parts/filter/Makefile.am b/parts/filter/Makefile.am
new file mode 100644
index 00000000..5a447405
--- /dev/null
+++ b/parts/filter/Makefile.am
@@ -0,0 +1,17 @@
+# Here resides the filter part
+
+INCLUDES = -I$(top_srcdir)/lib/interfaces -I$(top_srcdir)/lib/util $(all_includes)
+
+kde_module_LTLIBRARIES = libkdevfilter.la
+libkdevfilter_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevfilter_la_LIBADD = $(top_builddir)/lib/libkdevelop.la
+
+libkdevfilter_la_SOURCES = filterpart.cpp shellfilterdlg.cpp shellinsertdlg.cpp kdevfilterIface.cpp kdevfilterIface.skel
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevfilter.desktop
+
+rcdir = $(kde_datadir)/kdevfilter
+rc_DATA = kdevfilter.rc