summaryrefslogtreecommitdiffstats
path: root/parts/tipofday/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'parts/tipofday/Makefile.am')
-rw-r--r--parts/tipofday/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/parts/tipofday/Makefile.am b/parts/tipofday/Makefile.am
new file mode 100644
index 00000000..14e3a349
--- /dev/null
+++ b/parts/tipofday/Makefile.am
@@ -0,0 +1,24 @@
+INCLUDES = -I$(top_srcdir)/lib/interfaces -I$(top_srcdir)/lib/util $(all_includes)
+
+kde_module_LTLIBRARIES = libkdevtipofday.la
+libkdevtipofday_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevtipofday_la_LIBADD = $(top_builddir)/lib/libkdevelop.la
+
+libkdevtipofday_la_SOURCES = tipofday_part.cpp
+
+METASOURCES = AUTO
+KDE_ICON = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevtipofday.desktop
+
+tip_DATA = tips
+tipdir = $(kde_datadir)/kdevtipofday
+
+rc_DATA = kdevpart_tipofday.rc
+rcdir = $(kde_datadir)/kdevtipofday
+
+messages: rc.cpp
+ $(PREPARETIPS) > tips.cc
+ $(XGETTEXT) *.cpp *.h tips.cc -o $(podir)/kdevtipofday.pot
+ rm -f tips.cc