summaryrefslogtreecommitdiffstats
path: root/tdefilereplace/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:06:46 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:06:46 -0600
commitef2264e9790ae7e700ad3cf5fb3dbad05efd98d8 (patch)
treeac4650a642d502c458d0b654c8b731739ce601dc /tdefilereplace/CMakeLists.txt
parenta32b928478b59d4fa8b8495bbad6864476c129b1 (diff)
downloadtdewebdev-ef2264e9790ae7e700ad3cf5fb3dbad05efd98d8.tar.gz
tdewebdev-ef2264e9790ae7e700ad3cf5fb3dbad05efd98d8.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdefilereplace/CMakeLists.txt')
-rw-r--r--tdefilereplace/CMakeLists.txt56
1 files changed, 56 insertions, 0 deletions
diff --git a/tdefilereplace/CMakeLists.txt b/tdefilereplace/CMakeLists.txt
new file mode 100644
index 00000000..621c0e02
--- /dev/null
+++ b/tdefilereplace/CMakeLists.txt
@@ -0,0 +1,56 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( toolbar )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+tde_install_icons( )
+install( FILES tdefilereplace.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+install( FILES tdefilereplacepart.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES tdefilereplacepartui.rc DESTINATION ${DATA_INSTALL_DIR}/tdefilereplacepart )
+install( FILES tdefilereplaceui.rc DESTINATION ${DATA_INSTALL_DIR}/tdefilereplace )
+
+
+##### libtdefilereplacepart (module) ##############
+
+tde_add_kpart( libtdefilereplacepart AUTOMOC
+ SOURCES
+ commandengine.cpp configurationclasses.cpp
+ tdefilereplacepart.cpp tdefilereplaceview.cpp
+ tdefilereplaceviewwdg.ui kaddstringdlg.cpp kaddstringdlgs.ui
+ knewprojectdlg.cpp knewprojectdlgs.ui koptionsdlg.cpp
+ koptionsdlgs.ui tdefilereplacelib.cpp report.cpp
+ LINK tdeio-shared tdeparts-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### tdefilereplace (executable) #################
+
+tde_add_executable( tdefilereplace AUTOMOC
+ SOURCES
+ tdefilereplace.cpp main.cpp
+ LINK tdeio-shared tdeparts-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)