summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..94379de
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = kcm_kdmtheme.la
+
+kcm_kdmtheme_la_SOURCES = kdmtheme.cpp
+kcm_kdmtheme_la_LIBADD = -lkio -lknewstuff $(LIB_KDEUI)
+kcm_kdmtheme_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries)
+
+
+xdg_apps_DATA = kdmtheme.desktop
+
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmkdmtheme.pot