summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index afa9cb7..cba44df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -105,15 +105,14 @@ add_subdirectory( xslt )
tde_conditional_add_project_docs( BUILD_DOC )
tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
-install( FILES tellico.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
+tde_create_translated_desktop( tellico.desktop )
+tde_create_translated_desktop(
+ SOURCE x-tellico.desktop
+ DESTINATION ${MIME_INSTALL_DIR}/application
)
install( FILES tellico.xml
DESTINATION ${XDG_MIME_INSTALL_DIR}
)
-install( FILES x-tellico.desktop
- DESTINATION ${MIME_INSTALL_DIR}/application
-)
install( FILES tellico.dtd tellico.tips
DESTINATION ${DATA_INSTALL_DIR}/${CMAKE_PROJECT_NAME}
)