summaryrefslogtreecommitdiffstats
path: root/src/commands/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/commands/CMakeLists.txt')
-rw-r--r--src/commands/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/commands/CMakeLists.txt b/src/commands/CMakeLists.txt
new file mode 100644
index 0000000..e0628fc
--- /dev/null
+++ b/src/commands/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2016 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### commands (static) #########################
+
+tde_add_library( commands STATIC_PIC AUTOMOC
+ SOURCES
+ addentries.cpp modifyentries.cpp removeentries.cpp
+ addloans.cpp modifyloans.cpp removeloans.cpp
+ fieldcommand.cpp filtercommand.cpp reorderfields.cpp
+ group.cpp collectioncommand.cpp renamecollection.cpp
+ updateentries.cpp
+)