summaryrefslogtreecommitdiffstats
path: root/src/translators/pilotdb/libpalm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/translators/pilotdb/libpalm/CMakeLists.txt')
-rw-r--r--src/translators/pilotdb/libpalm/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/translators/pilotdb/libpalm/CMakeLists.txt b/src/translators/pilotdb/libpalm/CMakeLists.txt
new file mode 100644
index 0000000..af5d274
--- /dev/null
+++ b/src/translators/pilotdb/libpalm/CMakeLists.txt
@@ -0,0 +1,29 @@
+#################################################
+#
+# (C) 2016 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### pilotdb_palm (static) #####################
+
+tde_add_library( pilotdb_palm STATIC_PIC AUTOMOC
+ SOURCES Database.cpp Block.cpp
+)