summaryrefslogtreecommitdiffstats
path: root/designer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'designer/CMakeLists.txt')
-rw-r--r--designer/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/designer/CMakeLists.txt b/designer/CMakeLists.txt
new file mode 100644
index 0000000..91cb885
--- /dev/null
+++ b/designer/CMakeLists.txt
@@ -0,0 +1,24 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/qt
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### qscintillaplugin (shared)
+
+tde_add_library( qscintillaplugin SHARED
+
+ SOURCES
+ qscintillaplugin.cpp
+ LINK
+ qscintilla-shared
+
+ DESTINATION ${TQT_PLUGINS_DIR}/designer
+)