summaryrefslogtreecommitdiffstats
path: root/qmake/generators/win32/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qmake/generators/win32/CMakeLists.txt')
-rw-r--r--qmake/generators/win32/CMakeLists.txt92
1 files changed, 92 insertions, 0 deletions
diff --git a/qmake/generators/win32/CMakeLists.txt b/qmake/generators/win32/CMakeLists.txt
new file mode 100644
index 00000000..fdb01071
--- /dev/null
+++ b/qmake/generators/win32/CMakeLists.txt
@@ -0,0 +1,92 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/qmake
+ ${CMAKE_SOURCE_DIR}/qmake/generators
+ ${CMAKE_SOURCE_DIR}/mkspecs/linux-g++-64
+ ${CMAKE_BINARY_DIR}/include
+)
+
+link_directories()
+
+remove_definitions( -DTQT_THREAD_SUPPORT )
+
+
+##### tqmake-tools (static)
+
+set( target tqmake-tools )
+set( _SRC_ ${CMAKE_SOURCE_DIR}/src/tools/qstring.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qtextstream.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qiodevice.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qglobal.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qgdict.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qcstring.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qdatastream.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qgarray.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qbuffer.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qglist.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qptrcollection.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qfile.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qfile_unix.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qregexp.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qgvector.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qgcache.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qbitarray.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qdir.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/quuid.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qfileinfo_unix.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qdir_unix.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qfileinfo.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qdatetime.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qstringlist.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qmap.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qsettings.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qlocale.cpp
+ ${CMAKE_BINARY_DIR}/src/tools/qconfig.cpp
+ ${CMAKE_SOURCE_DIR}/src/tools/qunicodetables.cpp
+)
+
+tde_add_library( tqmake-tools STATIC_PIC
+
+ SOURCES
+ ${_SRC_}
+ LINK_PRIVATE
+ ${_UUID_LIBRARIES}
+
+ DEPENDENCIES
+ tqt-includes
+)
+set_property( TARGET ${target}-static
+ APPEND PROPERTY COMPILE_DEFINITIONS
+ TQT_NO_TEXTCODEC TQT_NO_UNICODETABLES TQT_NO_COMPONENT TQT_NO_STL TQT_NO_COMPRESS
+)
+
+
+##### win32-generator (static)
+
+set( target win32-generator )
+set( _SRC_ msvc_nmake.cpp
+ borland_bmake.cpp
+ winmakefile.cpp
+ msvc_objectmodel.cpp
+ mingw_make.cpp
+ msvc_dsp.cpp
+ msvc_vcproj.cpp
+)
+
+tde_add_library( ${target} STATIC_PIC
+
+ SOURCES
+ ${_SRC_}
+ LINK
+ ${_UUID_LIBRARIES}
+ tqmake-tools-static
+
+ DEPENDENCIES
+ tqt-includes
+)
+
+#mingw_make.cpp
+#msvc_dsp.cpp
+#msvc_vcproj.cpp