summaryrefslogtreecommitdiffstats
path: root/tools/designer/editor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/designer/editor/CMakeLists.txt')
-rw-r--r--tools/designer/editor/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/tools/designer/editor/CMakeLists.txt b/tools/designer/editor/CMakeLists.txt
new file mode 100644
index 00000000..9d4070d6
--- /dev/null
+++ b/tools/designer/editor/CMakeLists.txt
@@ -0,0 +1,41 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/mkspecs/linux-g++-64
+ ${CMAKE_BINARY_DIR}/include
+ ${ZLIB_INCLUDE_DIRS}
+)
+
+link_directories()
+
+
+##### tqteditor (shared)
+
+set( target tqteditor )
+
+set( ${target}_SOURCES
+ editor.cpp
+ parenmatcher.cpp
+ completion.cpp
+ viewmanager.cpp
+ markerwidget.cpp
+ conf.cpp
+ browser.cpp
+ arghintwidget.cpp
+ cindent.cpp
+ yyindent.cpp
+
+ preferences.ui
+)
+
+tde_add_library( ${target} SHARED
+ SOURCES ${${target}_SOURCES}
+ LINK tqt-mt-shared
+ VERSION 1.0.0
+ DESTINATION ${LIB_INSTALL_DIR}
+ DEPENDENCIES tquic
+)
+
+tqt_automoc( ${target}-shared )