summaryrefslogtreecommitdiffstats
path: root/tools/linguist/tutorial/tt3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/linguist/tutorial/tt3/CMakeLists.txt')
-rw-r--r--tools/linguist/tutorial/tt3/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/linguist/tutorial/tt3/CMakeLists.txt b/tools/linguist/tutorial/tt3/CMakeLists.txt
new file mode 100644
index 00000000..1d0eafeb
--- /dev/null
+++ b/tools/linguist/tutorial/tt3/CMakeLists.txt
@@ -0,0 +1,28 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/mkspecs/linux-g++-64
+ ${CMAKE_BINARY_DIR}/include
+ ${ZLIB_INCLUDE_DIRS}
+)
+
+link_directories()
+
+
+##### tt3 (executable)
+
+set( target tt3 )
+
+tde_add_executable( ${target}
+ SOURCES
+ main.cpp
+ mainwindow.cpp
+ printpanel.cpp
+
+ LINK
+ tqt-mt-shared
+)
+
+tqt_automoc( ${target} )