summaryrefslogtreecommitdiffstats
path: root/arch/tde-core/tde-tqca-tls/PKGBUILD
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-09-20 17:08:32 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2021-09-29 06:38:40 +0000
commit018f946ee70600993c60a74046f417ca05bdb41b (patch)
tree37829ad4f8af4005172148ee78ab38b67328cecb /arch/tde-core/tde-tqca-tls/PKGBUILD
parent2bcda9ee7da7582ee0e550a71b9f865cac76dce2 (diff)
downloadtde-packaging-018f946ee70600993c60a74046f417ca05bdb41b.tar.gz
tde-packaging-018f946ee70600993c60a74046f417ca05bdb41b.zip
ArchLinux: Take a newer state of pkgbuilds from Michael Manley
Clean old long-term not maintained pkgbuilds. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'arch/tde-core/tde-tqca-tls/PKGBUILD')
-rw-r--r--arch/tde-core/tde-tqca-tls/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/arch/tde-core/tde-tqca-tls/PKGBUILD b/arch/tde-core/tde-tqca-tls/PKGBUILD
new file mode 100644
index 000000000..db87b201d
--- /dev/null
+++ b/arch/tde-core/tde-tqca-tls/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Michael Manley <mmanley@nasutek.com>
+# Contributor: Pawel 'l0ner' Soltys <pwslts@gmail.com>
+# Contributor: Calvin Morrison <mutantturkey@gmail.com>
+# Contributor: David C. Rankin <drankinatty at gmail dot com>
+
+pkgname=tde-tqca-tls
+pkgver=14.0.5
+pkgrel=1
+pkgdesc="Trinity SSL/TLS plugin for TQt Cryptographic Architecture (TQCA)"
+arch=('i686' 'x86_64')
+url='http://scm.trinitydesktop.org/scm/git/tqca-tls'
+license=('GPL')
+groups=('tde-core')
+depends=('tde-tqtinterface' 'openssl-1.0')
+makedepends=('pkgconfig')
+provides=('tqca-tls')
+conflicts=('trinity-tqca-tls')
+replaces=('trinity-tqca-tls')
+options=('staticlibs' 'libtool' '!strip')
+source=("http://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/dependencies/tqca-tls-R${pkgver}.tar.bz2")
+md5sums=('21dd2d8680bdfccbbb68616682d5e898')
+
+build() {
+ cd ${srcdir}/dependencies/${pkgname#*-}
+
+ msg "Starting configure..."
+ ./configure --qtdir=${QTDIR} --with-openssl-inc=/usr/include/openssl-1.0 \
+ --with-openssl-lib=/usr/lib/openssl-1.0
+
+ msg "Building - $pkgname..."
+ make || return 1
+}
+
+package() {
+ msg "Packaging - $pkgname"
+ cd ${srcdir}/dependencies/${pkgname#*-}
+ make INSTALL_ROOT="${pkgdir}" install
+}