summaryrefslogtreecommitdiffstats
path: root/arch/tde-extra/tde-tdesudo/PKGBUILD
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-09-20 17:08:32 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2021-09-29 06:38:40 +0000
commit018f946ee70600993c60a74046f417ca05bdb41b (patch)
tree37829ad4f8af4005172148ee78ab38b67328cecb /arch/tde-extra/tde-tdesudo/PKGBUILD
parent2bcda9ee7da7582ee0e550a71b9f865cac76dce2 (diff)
downloadtde-packaging-018f946ee70600993c60a74046f417ca05bdb41b.tar.gz
tde-packaging-018f946ee70600993c60a74046f417ca05bdb41b.zip
ArchLinux: Take a newer state of pkgbuilds from Michael Manley
Clean old long-term not maintained pkgbuilds. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'arch/tde-extra/tde-tdesudo/PKGBUILD')
-rw-r--r--arch/tde-extra/tde-tdesudo/PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/arch/tde-extra/tde-tdesudo/PKGBUILD b/arch/tde-extra/tde-tdesudo/PKGBUILD
new file mode 100644
index 000000000..17739ab81
--- /dev/null
+++ b/arch/tde-extra/tde-tdesudo/PKGBUILD
@@ -0,0 +1,56 @@
+# Contributor: e1z0 <justinas at eofnet dot lt>
+
+pkgname=tde-tdesudo
+pkgver=14.0.5
+pkgrel=1
+pkgdesc="TDE Sudo"
+arch=('i686' 'x86_64')
+url='http://scm.trinitydesktop.org/scm/git/applications/tdesudo'
+license=('GPL')
+groups=('tde-extra')
+depends=('tde-tdebase')
+makedepends=('pkgconfig' 'automake')
+#provides=('tdesudo')
+#conflicts=('tdesudo')
+#replaces=('tdesudo')
+options=('staticlibs' 'libtool' '!strip')
+source=("http://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/applications/tdesudo-R${pkgver}.tar.bz2")
+md5sums=('8f86b7b497a9575979b27fd2911b0106')
+# install=''
+
+build() {
+ # old ruby1.8 path
+ export PATH=/opt/ruby1.8/bin:$PATH
+ ## Generate config files and update with autoreconf
+ cd ${srcdir}/applications/${pkgname#*-}
+
+ msg "Copying system libtool files...."
+ cp /usr/share/aclocal/libtool.m4 ./admin/libtool.m4.in
+ cp /usr/share/libtool/build-aux/ltmain.sh ./admin/ltmain.sh
+
+ msg "Running make -f admin/Makefile.common ...."
+ make -f admin/Makefile.common
+
+ ## configure
+ msg "Configuring - ${pkgname#*-}..."
+ CFLAGS="${CFLAGS} -fpermissive" \
+ CXXFLAGS="${CXXFLAGS} -fpermissive" \
+ ./configure \
+ --prefix=${TDEDIR} \
+ --with-qt-dir=${QTDIR} \
+ --with-qt-includes=${QTDIR}/include \
+ --with-qt-libraries=${QTDIR}/lib \
+ --sysconfdir=${TDEDIR}/etc \
+ --localstatedir=/var \
+ --enable-closure
+
+ msg "Building - ${pkgname#*-}..."
+make $NUMJOBS
+}
+
+package() {
+msg "Packaging - $pkgname-$pkgver"
+ cd ${srcdir}/applications/${pkgname#*-} # use for libtool
+
+make -j1 DESTDIR="${pkgdir}" install
+}