summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/desktop-effects-tde/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 23:02:46 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 23:02:46 +0900
commitfcad8b8d150fb9f508973e3044a103de74ec3877 (patch)
treeca34a8cf3bfbe08335d40c47863b4901e1d19609 /debian/_base/applications/desktop-effects-tde/debian/rules
parent5d8ed1fab813d86b04383f7fcf8ab2c994cbea30 (diff)
downloadtde-packaging-fcad8b8d150fb9f508973e3044a103de74ec3877.tar.gz
tde-packaging-fcad8b8d150fb9f508973e3044a103de74ec3877.zip
DEB: use _base folder for a distro instead of specific distros (squeeze and maverick).
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'debian/_base/applications/desktop-effects-tde/debian/rules')
-rwxr-xr-xdebian/_base/applications/desktop-effects-tde/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/_base/applications/desktop-effects-tde/debian/rules b/debian/_base/applications/desktop-effects-tde/debian/rules
new file mode 100755
index 000000000..41ad63be2
--- /dev/null
+++ b/debian/_base/applications/desktop-effects-tde/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+binary-install/desktop-effects-tde-trinity::
+ ${DH_PYTHON2} -pdesktop-effects-tde-trinity