summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kerry/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-05-28 13:57:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-05-28 14:00:01 +0200
commiteff6366279993eb27dc55b4e41a8ec8b4e4ec278 (patch)
treef794a3d3138dfcfb85e8e66d1fb4dc1b119d4403 /debian/_base/applications/kerry/debian/rules
parent5fb1e75a0367f8a52446b8e3b22d0d5f18840981 (diff)
downloadtde-packaging-eff6366279993eb27dc55b4e41a8ec8b4e4ec278.tar.gz
tde-packaging-eff6366279993eb27dc55b4e41a8ec8b4e4ec278.zip
DEB kerry: Switch to cmake.
The man page has been moved to the main tree. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 27ff58e5d4d4fedda24dd05e284bb3010b41544b)
Diffstat (limited to 'debian/_base/applications/kerry/debian/rules')
-rwxr-xr-xdebian/_base/applications/kerry/debian/rules36
1 files changed, 11 insertions, 25 deletions
diff --git a/debian/_base/applications/kerry/debian/rules b/debian/_base/applications/kerry/debian/rules
index a84cc1fed..cee2a3058 100755
--- a/debian/_base/applications/kerry/debian/rules
+++ b/debian/_base/applications/kerry/debian/rules
@@ -1,33 +1,19 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
-DEB_INSTALL_MANPAGES_kerry-trinity = kerry.1
-
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-build/kerry-trinity::
- docbook2x-man debian/kerry.1.docbook
-
-clean::
- rm -f kerry.1
-
-binary-post-install/kerry-trinity::
- chrpath -d debian/kerry-trinity/opt/trinity/lib/libtdeinit_kerry.so
- chrpath -d debian/kerry-trinity/opt/trinity/bin/kerry
- chrpath -d debian/kerry-trinity/opt/trinity/lib/trinity/kerry.so
- chrpath -d debian/kerry-trinity/opt/trinity/lib/trinity/kcm_beagle.so
- mkdir -p debian/kerry-trinity/opt/trinity/share/man/man1/
- mv debian/kerry-trinity/usr/share/man/man1/kerry.1 debian/kerry-trinity/opt/trinity/share/man/man1/kerry.1
- rm -rf debian/kerry-trinity/usr/share/man
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"