summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/tdesvn/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:45:52 +0800
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:45:52 +0800
commiteb16e7c7281e182297581fa8d565561869c81bca (patch)
tree4edf3c2dcd2a70e76c9581f04fbeb7d2a729f8b6 /debian/_base/applications/tdesvn/debian/rules
parent2064c92d78e53c5753ccc22a2b83abfe120fa8cb (diff)
downloadtde-packaging-eb16e7c7281e182297581fa8d565561869c81bca.tar.gz
tde-packaging-eb16e7c7281e182297581fa8d565561869c81bca.zip
DEB: added cmake directive to create compilation database 'compile_commands.json' at build time.
This can be used to provide linting, autocompletion, hovering info, go-to-definition and in general other LSP functionality in development environments. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'debian/_base/applications/tdesvn/debian/rules')
-rwxr-xr-xdebian/_base/applications/tdesvn/debian/rules16
1 files changed, 14 insertions, 2 deletions
diff --git a/debian/_base/applications/tdesvn/debian/rules b/debian/_base/applications/tdesvn/debian/rules
index b142b22ec..7c91ce434 100755
--- a/debian/_base/applications/tdesvn/debian/rules
+++ b/debian/_base/applications/tdesvn/debian/rules
@@ -17,8 +17,20 @@ DEB_KDE_APIDOX := yes
CXXFLAGS := -DSMB_CTX_FLAG_USE_KERBEROS -DSMB_CTX_FLAG_FALLBACK_AFTER_KERBEROS -g -Wall $(DEB_OPT_FLAG)
-DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
--DCMAKE_BUILD_TYPE=RelWithDebInfo
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DLIB_SUFFIX="" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" \
+ -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" \
+ -DAUTODETECT_QT_DIRS="ON" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DBUILD_ALL="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)