summaryrefslogtreecommitdiffstats
path: root/debian/_base/core/tdemultimedia
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-04-04 03:02:11 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-04-04 15:53:01 +0200
commit3d0fe45a7b0b586d096644a3581df8307787eb3a (patch)
treef6e05af72fa60089c8db1e9999d982d47be07bc8 /debian/_base/core/tdemultimedia
parent5d067f8a1c69ffd2585cd3a46f0601cc552e40d2 (diff)
downloadtde-packaging-3d0fe45a7b0b586d096644a3581df8307787eb3a.tar.gz
tde-packaging-3d0fe45a7b0b586d096644a3581df8307787eb3a.zip
DEB: Move DEB_DH_BUILDDEB_ARGS to common cdbs rules.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/_base/core/tdemultimedia')
-rw-r--r--debian/_base/core/tdemultimedia/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/core/tdemultimedia/debian/rules17
2 files changed, 10 insertions, 17 deletions
diff --git a/debian/_base/core/tdemultimedia/debian/cdbs/debian-tde.mk b/debian/_base/core/tdemultimedia/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/core/tdemultimedia/debian/cdbs/debian-tde.mk
+++ b/debian/_base/core/tdemultimedia/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/core/tdemultimedia/debian/rules b/debian/_base/core/tdemultimedia/debian/rules
index 7234ee70e..ea08bafa0 100755
--- a/debian/_base/core/tdemultimedia/debian/rules
+++ b/debian/_base/core/tdemultimedia/debian/rules
@@ -4,20 +4,6 @@ include /usr/share/cdbs/1/class/cmake.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := \
- --with-alsa --with-arts-alsa \
- --with-extra-includes=/usr/include/speex:/opt/trinity/include/tde/arts \
- --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
- # The include/tde/arts one should be temporary. See
- # "juk/Makefile.am: arts_includes vs ARTS_CFLAGS" in -talk.
-
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \
@@ -38,9 +24,6 @@ DOC_HTML_PRUNE := kcontrol-trinity
DEB_DH_STRIP_ARGS := --dbg-package=tdemultimedia-trinity-dbg
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
PACKAGES_WITH_LIBS := artsbuilder-trinity tdemultimedia-tdeio-plugins-trinity tdemid-trinity kmix-trinity krec-trinity \
libarts1-akode-trinity libarts1-audiofile-trinity libarts1-mpeglib-trinity libarts1-xine-trinity \
libkcddb1-trinity mpeglib-trinity noatun-trinity