summaryrefslogtreecommitdiffstats
path: root/debian/_base/metapackages/desktop-base/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-10-01 00:26:56 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-10-01 00:26:56 +0900
commitcb2eb4a925c0e2642984c0d3ce129c4c86e2c8b6 (patch)
tree03ca3acf7c59e8113c89b0349c8b06a24e682e82 /debian/_base/metapackages/desktop-base/debian/rules
parent4cc67abd61d034541303fac26d25e2f83c2b9749 (diff)
downloadtde-packaging-cb2eb4a925c0e2642984c0d3ce129c4c86e2c8b6.tar.gz
tde-packaging-cb2eb4a925c0e2642984c0d3ce129c4c86e2c8b6.zip
DEB: updated after metapackages have been consolidated in one folder in main repo.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'debian/_base/metapackages/desktop-base/debian/rules')
-rwxr-xr-xdebian/_base/metapackages/desktop-base/debian/rules30
1 files changed, 30 insertions, 0 deletions
diff --git a/debian/_base/metapackages/desktop-base/debian/rules b/debian/_base/metapackages/desktop-base/debian/rules
new file mode 100755
index 000000000..67ba1f7f8
--- /dev/null
+++ b/debian/_base/metapackages/desktop-base/debian/rules
@@ -0,0 +1,30 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/buildcore.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/makefile.mk
+
+pre-build:: debian/stamp-distrospecific
+
+debian/stamp-distrospecific:
+ dh_testdir
+ [ -e debian/stamp-distrospecific ] || \
+ ls -a1 debian/distrospecific | grep -v "^\.*$$" | \
+ tee debian/stamp-distrospecific | \
+ tr "\n" "\0" | (cd debian/distrospecific && xargs -r0 mv -t ../..)
+
+clean::
+ dh_testdir
+ [ ! -e debian/stamp-distrospecific ] || \
+ cat debian/stamp-distrospecific | \
+ tr "\n" "\0" | xargs -r0 mv -t debian/distrospecific
+ rm -f debian/stamp-distrospecific
+
+# needed for usplash
+CFLAGS += -fPIC
+
+DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/desktop-base-trinity/
+
+binary-fixup/desktop-base::
+ dh_gconf --priority=15
+