summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/dolphin/debian/cdbs
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-02-15 02:02:15 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-02-15 02:02:15 +0100
commitea1cb59b6822e0369e144c6cb66437b27dcabaa6 (patch)
treec6b937a20cf849ec271048dd11258f7056702042 /debian/lenny/applications/dolphin/debian/cdbs
parent83d64901baf068948bec2c588c99f11cf948be9c (diff)
downloadtde-packaging-ea1cb59b6822e0369e144c6cb66437b27dcabaa6.tar.gz
tde-packaging-ea1cb59b6822e0369e144c6cb66437b27dcabaa6.zip
DEB dolphin: The man page has been moved to the main tree.
Modify the rules into line with the usual. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/lenny/applications/dolphin/debian/cdbs')
-rw-r--r--debian/lenny/applications/dolphin/debian/cdbs/debian-qt-kde.mk20
-rw-r--r--debian/lenny/applications/dolphin/debian/cdbs/kde.mk10
2 files changed, 26 insertions, 4 deletions
diff --git a/debian/lenny/applications/dolphin/debian/cdbs/debian-qt-kde.mk b/debian/lenny/applications/dolphin/debian/cdbs/debian-qt-kde.mk
index 2dff59226..60310a01a 100644
--- a/debian/lenny/applications/dolphin/debian/cdbs/debian-qt-kde.mk
+++ b/debian/lenny/applications/dolphin/debian/cdbs/debian-qt-kde.mk
@@ -10,6 +10,16 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
@@ -94,6 +104,16 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
rm -f debian/stamp-cvs-make
endif
diff --git a/debian/lenny/applications/dolphin/debian/cdbs/kde.mk b/debian/lenny/applications/dolphin/debian/cdbs/kde.mk
index f5d237249..80176d63e 100644
--- a/debian/lenny/applications/dolphin/debian/cdbs/kde.mk
+++ b/debian/lenny/applications/dolphin/debian/cdbs/kde.mk
@@ -35,7 +35,9 @@ else
DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
endif
-# include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
export kde_cgidir = \$${libdir}/cgi-bin
export kde_confdir = \$${sysconfdir}/trinity
@@ -59,7 +61,7 @@ endif
cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/"
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
@@ -70,12 +72,12 @@ cleanbuilddir::
common-build-arch common-build-indep:: debian/stamp-kde-apidox
debian/stamp-kde-apidox:
-# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
touch $@
common-install-arch common-install-indep:: common-install-kde-apidox
common-install-kde-apidox::
-# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
clean::
rm -f debian/stamp-kde-apidox