summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/kio-locate/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
commit0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6 (patch)
treec0d0d652fef20159e78fa20b2567661bd7db8e41 /debian/lenny/applications/kio-locate/debian/rules
parent6b027437fd51e7874aaffed9e395ddf7913c3ab4 (diff)
downloadtde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.tar.gz
tde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.zip
Add initial Debian Lenny/Squeeze packaging as well as symlink Lucid to Maverick
Diffstat (limited to 'debian/lenny/applications/kio-locate/debian/rules')
-rwxr-xr-xdebian/lenny/applications/kio-locate/debian/rules37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/lenny/applications/kio-locate/debian/rules b/debian/lenny/applications/kio-locate/debian/rules
new file mode 100755
index 000000000..f10f5f7c1
--- /dev/null
+++ b/debian/lenny/applications/kio-locate/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_COMPRESS_EXCLUDE=.docbook
+DEB_SCONS_PREFIX=/opt/trinity
+
+CONFIG_STATUS=$(DEB_BUILDDIR)/config.status
+SCONS_CMD=/usr/bin/scons
+
+common-configure-arch common-configure-indep:: common-configure-impl
+common-configure-impl:: $(CONFIG_STATUS)
+$(CONFIG_STATUS):
+ env PATH=/opt/trinity/bin:$(PATH) $(SCONS_CMD) configure prefix=$(DEB_DESTDIR)$(DEB_SCONS_PREFIX)
+ touch $(CONFIG_STATUS)
+
+common-build-arch common-build-indep:: common-build-impl
+common-build-impl::
+ env PATH=/opt/trinity/bin:$(PATH) $(SCONS_CMD)
+ rm -f doc/en/index.cache.bz2
+
+common-install-arch common-install-indep:: common-install-impl
+common-install-impl::
+ env PATH=/opt/trinity/bin:$(PATH) DESTDIR=$(DEB_DESTDIR) $(SCONS_CMD) install
+
+clean::
+ rm -rf build cache scons-mini
+ rm -f admin/*.pyc $(CONFIG_STATUS)
+
+DEB_INSTALL_DOCS_kio-locate-trinity := -XREADME -XNEWS -XTODO -XAUTHORS