summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/tdepowersave/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-10-06 02:08:39 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-10-06 02:08:39 +0200
commit89a05bd6892fe4d744b81917cfaa91d1d47a071c (patch)
treecb88f4325e608a145a5949351e4217c299df023f /debian/lenny/applications/tdepowersave/debian/rules
parent2c4f95384dfba906fafaa7cd6864e667d9972d19 (diff)
downloadtde-packaging-89a05bd6892fe4d744b81917cfaa91d1d47a071c.tar.gz
tde-packaging-89a05bd6892fe4d744b81917cfaa91d1d47a071c.zip
Switch tdepowersave to cmake on Debian and Ubuntu
Diffstat (limited to 'debian/lenny/applications/tdepowersave/debian/rules')
-rwxr-xr-xdebian/lenny/applications/tdepowersave/debian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/lenny/applications/tdepowersave/debian/rules b/debian/lenny/applications/tdepowersave/debian/rules
index f74a76605..a891b0150 100755
--- a/debian/lenny/applications/tdepowersave/debian/rules
+++ b/debian/lenny/applications/tdepowersave/debian/rules
@@ -1,5 +1,6 @@
#!/usr/bin/make -f
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/kde.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/rules/patchsys-quilt.mk
@@ -17,9 +18,20 @@ DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinit
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON"
+
post-patches:: debian/stamp-bootstrap
debian/stamp-bootstrap:
+ifndef _cdbs_class_cmake
! [ -f /usr/share/libtool/ltmain.sh ] || \
cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
! [ -f /usr/share/libtool/config/ltmain.sh ] || \
@@ -27,6 +39,7 @@ debian/stamp-bootstrap:
cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
make -f admin/Makefile.common cvs
+endif
touch debian/stamp-bootstrap
install/tdepowersave-trinity::