summaryrefslogtreecommitdiffstats
path: root/debian/lenny
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-11-06 16:24:40 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-11-06 16:24:40 -0600
commit3353bed16646485b6df40dcb884952df0a15dace (patch)
tree331a7bba78d38cbc2d9ecdf1e4c9f4555f8cb7f7 /debian/lenny
parentb45eda74efcfcf517b9b952c23e509409651b2ff (diff)
downloadtde-packaging-3353bed16646485b6df40dcb884952df0a15dace.tar.gz
tde-packaging-3353bed16646485b6df40dcb884952df0a15dace.zip
Update Debian and Ubuntu packaging for latest Qt3/TQt3 file conflict renaming
Diffstat (limited to 'debian/lenny')
-rw-r--r--debian/lenny/dependencies/tqt3/debian/README.Debian8
-rw-r--r--debian/lenny/dependencies/tqt3/debian/libtqt3-headers.install2
-rwxr-xr-xdebian/lenny/dependencies/tqt3/debian/rules52
-rw-r--r--debian/lenny/dependencies/tqt3/debian/tqt3-designer.install4
-rw-r--r--debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-compat.install12
-rw-r--r--debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.install4
-rw-r--r--debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.links4
7 files changed, 43 insertions, 43 deletions
diff --git a/debian/lenny/dependencies/tqt3/debian/README.Debian b/debian/lenny/dependencies/tqt3/debian/README.Debian
index 99b460974..63996972e 100644
--- a/debian/lenny/dependencies/tqt3/debian/README.Debian
+++ b/debian/lenny/dependencies/tqt3/debian/README.Debian
@@ -136,8 +136,8 @@ Designer or extend the Designer as well as utilizing the Qt Assistant by
calling it from within your program, install tqt3-apps-dev, which contains
the static libraries and header files retquired for this functionality.
-For Embedded Developers, the program qvfb (Qt Virtual Frambuffer) and
-makeqpf (embedded fonts tool)have been packaged into
+For Embedded Developers, the program tqvfb (Qt Virtual Frambuffer) and
+maketqpf (embedded fonts tool)have been packaged into
qt3-dev-tools-embedded. For developers that work on migrating their program
from any Qt version prior to Qt 3.x to the Qt 3.x platform you will find
additional tools in the tqt3-dev-tools-compat.
@@ -257,8 +257,8 @@ the naming convention. The filenames are now all following the scheme
ClassName -> classname.h.
Therefore, if you are the developer of the affected program, change your
-sources according to this scheme. Qt ships with two tools, qt20fix and
-qtrename140, to help developers migrate their API to the Qt 3 version,
+sources according to this scheme. Qt ships with two tools, tqt20fix and
+tqtrename140, to help developers migrate their API to the Qt 3 version,
which can help you in the transition upgrade to Qt 3.
If you are affected by this as a packager, notify upstream to fix those
diff --git a/debian/lenny/dependencies/tqt3/debian/libtqt3-headers.install b/debian/lenny/dependencies/tqt3/debian/libtqt3-headers.install
index 32d3bb87d..5afd749f5 100644
--- a/debian/lenny/dependencies/tqt3/debian/libtqt3-headers.install
+++ b/debian/lenny/dependencies/tqt3/debian/libtqt3-headers.install
@@ -253,7 +253,7 @@ usr/include/tqt3/ntqvaluevector.h
usr/include/tqt3/ntqvariant.h
usr/include/tqt3/ntqvbox.h
usr/include/tqt3/ntqvbuttongroup.h
-usr/include/tqt3/ntqvfbhdr.h
+usr/include/tqt3/nttqvfbhdr.h
usr/include/tqt3/ntqvgroupbox.h
usr/include/tqt3/ntqwaitcondition.h
usr/include/tqt3/ntqwhatsthis.h
diff --git a/debian/lenny/dependencies/tqt3/debian/rules b/debian/lenny/dependencies/tqt3/debian/rules
index 7e78b635b..780247eff 100755
--- a/debian/lenny/dependencies/tqt3/debian/rules
+++ b/debian/lenny/dependencies/tqt3/debian/rules
@@ -152,17 +152,17 @@ libqt-thread-stamp: post-patches
# archives get accidentally stripped by make install. Copy over unstripped ones for now.
cp lib/lib*.a $(TMP_INSTALL)/usr/lib/
- cp bin/qtrename140 $(TMP_INSTALL)/usr/bin/
- cp bin/qt20fix $(TMP_INSTALL)/usr/bin/
- cp bin/findtr $(TMP_INSTALL)/usr/bin/
+ cp bin/tqtrename140 $(TMP_INSTALL)/usr/bin/
+ cp bin/tqt20fix $(TMP_INSTALL)/usr/bin/
+ cp bin/tqtfindtr $(TMP_INSTALL)/usr/bin/
- # build conv2ui
- cd tools/designer/tools/conv2ui && $(MAKE)
- cp bin/conv2ui $(TMP_INSTALL)/usr/bin/conv2ui
+ # build tqtconv2ui
+ cd tools/designer/tools/tqtconv2ui && $(MAKE)
+ cp bin/tqtconv2ui $(TMP_INSTALL)/usr/bin/tqtconv2ui
- # build qvfb
- cd tools/qvfb/ && $(MAKE)
- cp tools/qvfb/qvfb $(TMP_INSTALL)/usr/bin/qvfb
+ # build tqvfb
+ cd tools/tqvfb/ && $(MAKE)
+ cp tools/tqvfb/tqvfb $(TMP_INSTALL)/usr/bin/tqvfb
# install qmake.cache file
install -d $(P_QTMTDEV)/usr/share/tqt3/
@@ -190,9 +190,9 @@ clean::
if [ -f "src/Makefile" ]; then \
$(MAKE) -C src clean; $(MAKE) -C plugins/src distclean; $(MAKE) -C tools distclean; \
- $(MAKE) -C tools/makeqpf distclean; $(MAKE) -C tools/qconfig distclean; $(MAKE) -C tools/qvfb distclean; \
- $(MAKE) -C tools/msg2qm distclean; $(MAKE) -C tools/mergetr distclean; $(MAKE) -C tools/qembed distclean; \
- $(MAKE) -C tools/designer/tools/conv2ui distclean; $(MAKE) -C tools/designer/tools/createcw distclean; \
+ $(MAKE) -C tools/maketqpf distclean; $(MAKE) -C tools/qconfig distclean; $(MAKE) -C tools/tqvfb distclean; \
+ $(MAKE) -C tools/msg2tqm distclean; $(MAKE) -C tools/tqtmergetr distclean; $(MAKE) -C tools/qembed distclean; \
+ $(MAKE) -C tools/designer/tools/tqtconv2ui distclean; $(MAKE) -C tools/designer/tools/tqtcreatecw distclean; \
$(MAKE) -C tools/designer/plugins/glade distclean; $(MAKE) -C tools/designer/plugins/qglwidget distclean; \
$(MAKE) -C config.tests/unix/largefile distclean; $(MAKE) -C qmake distclean; \
fi
@@ -351,10 +351,10 @@ binary-arch: build install
cp `pwd`/tools/designer/editor/*.h $(P_APPSDEV)/usr/include/tqt3/
rm -rf `pwd`/debian/tqt3-apps-dev/usr/include/tqt3/preferences.ui.h
- ## qvfb package
- install -m644 -D `pwd`/tools/qvfb/pda.skin `pwd`/debian/tqt3-dev-tools-embedded/etc/tqt3/qvfb/pda.skin
- install -m644 -D `pwd`/tools/qvfb/pda_down.png `pwd`/debian/tqt3-dev-tools-embedded/usr/share/qvfb/pda_down.png
- install -m644 -D `pwd`/tools/qvfb/pda_up.png `pwd`/debian/tqt3-dev-tools-embedded/usr/share/qvfb/pda_up.png
+ ## tqvfb package
+ install -m644 -D `pwd`/tools/tqvfb/pda.skin `pwd`/debian/tqt3-dev-tools-embedded/etc/tqt3/tqvfb/pda.skin
+ install -m644 -D `pwd`/tools/tqvfb/pda_down.png `pwd`/debian/tqt3-dev-tools-embedded/usr/share/tqvfb/pda_down.png
+ install -m644 -D `pwd`/tools/tqvfb/pda_up.png `pwd`/debian/tqt3-dev-tools-embedded/usr/share/tqvfb/pda_up.png
# remove utterly ugle symlink
rm -rf `pwd`/debian/tqt3-dev-tools//usr/share/tqt3/mkspecs/linux-g++/linux-g++
@@ -431,16 +431,16 @@ binary-arch: build install
rm -rf `pwd`/debian/tqt3-dev-tools/usr/bin/tqmake
install -D `pwd`/qmake/tqmake `pwd`/debian/tqt3-dev-tools/usr/bin/tqmake
- # Install source for the designer tools, such as createcw.
+ # Install source for the designer tools, such as tqtcreatecw.
cp -ra tools/designer/tools debian/tqt3-designer/usr/share/tqt3/tools
- rm -f debian/tqt3-designer/usr/share/tqt3/tools/createcw/createcw
- rm -rf debian/tqt3-designer/usr/share/tqt3/tools/createcw/.moc
- rm -rf debian/tqt3-designer/usr/share/tqt3/tools/createcw/.obj
- rm -f debian/tqt3-designer/usr/share/tqt3/tools/createcw/Makefile
- rm -f debian/tqt3-designer/usr/share/tqt3/tools/conv2ui/conv2ui
- rm -rf debian/tqt3-designer/usr/share/tqt3/tools/conv2ui/.moc
- rm -rf debian/tqt3-designer/usr/share/tqt3/tools/conv2ui/.obj
- rm -f debian/tqt3-designer/usr/share/tqt3/tools/conv2ui/Makefile
+ rm -f debian/tqt3-designer/usr/share/tqt3/tools/tqtcreatecw/tqtcreatecw
+ rm -rf debian/tqt3-designer/usr/share/tqt3/tools/tqtcreatecw/.moc
+ rm -rf debian/tqt3-designer/usr/share/tqt3/tools/tqtcreatecw/.obj
+ rm -f debian/tqt3-designer/usr/share/tqt3/tools/tqtcreatecw/Makefile
+ rm -f debian/tqt3-designer/usr/share/tqt3/tools/tqtconv2ui/tqtconv2ui
+ rm -rf debian/tqt3-designer/usr/share/tqt3/tools/tqtconv2ui/.moc
+ rm -rf debian/tqt3-designer/usr/share/tqt3/tools/tqtconv2ui/.obj
+ rm -f debian/tqt3-designer/usr/share/tqt3/tools/tqtconv2ui/Makefile
# run remaining debhelper scripts
dh_installdocs -a $(IBASE) -XREADME.Debian
@@ -464,7 +464,7 @@ binary-arch: build install
for a in `find debian/ -name '*.substvars'`; do cat "$$a" | sed 's/, xlibs (>> 4.1.0)//g' > "$$a".new && mv "$$a.new" "$$a"; done
# fix conffiles file for tqt3-dev-tools-embedded
- echo "/etc/tqt3/qvfb/pda.skin" > `pwd`/debian/tqt3-dev-tools-embedded/DEBIAN/conffiles
+ echo "/etc/tqt3/tqvfb/pda.skin" > `pwd`/debian/tqt3-dev-tools-embedded/DEBIAN/conffiles
dh_gencontrol -a $(IBASE)
dh_md5sums -a $(IBASE)
diff --git a/debian/lenny/dependencies/tqt3/debian/tqt3-designer.install b/debian/lenny/dependencies/tqt3/debian/tqt3-designer.install
index 555f8b9b4..296634002 100644
--- a/debian/lenny/dependencies/tqt3/debian/tqt3-designer.install
+++ b/debian/lenny/dependencies/tqt3/debian/tqt3-designer.install
@@ -1,6 +1,6 @@
usr/bin/tqdesigner
-usr/bin/createcw
-usr/bin/conv2ui
+usr/bin/tqtcreatecw
+usr/bin/tqtconv2ui
usr/share/tqt3/templates/*
usr/share/tqt3/doc/html/designer*html
usr/share/tqt3/doc/html/designer*dcf
diff --git a/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-compat.install b/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-compat.install
index 838f6b827..241ec8ee0 100644
--- a/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-compat.install
+++ b/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-compat.install
@@ -1,6 +1,6 @@
-usr/bin/qt20fix
-usr/bin/qtrename140
-usr/bin/qm2ts
-usr/bin/mergetr
-usr/bin/findtr
-usr/bin/msg2qm
+usr/bin/tqt20fix
+usr/bin/tqtrename140
+usr/bin/tqm2ts
+usr/bin/tqtmergetr
+usr/bin/tqtfindtr
+usr/bin/msg2tqm
diff --git a/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.install b/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.install
index 2954f7a4c..38a249f41 100644
--- a/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.install
+++ b/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.install
@@ -1,2 +1,2 @@
-usr/bin/makeqpf
-usr/bin/qvfb
+usr/bin/maketqpf
+usr/bin/tqvfb
diff --git a/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.links b/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.links
index a0274c505..72baff7fd 100644
--- a/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.links
+++ b/debian/lenny/dependencies/tqt3/debian/tqt3-dev-tools-embedded.links
@@ -1,2 +1,2 @@
-/usr/bin/makeqpf /usr/share/tqt3/bin/makeqpf
-/usr/bin/qvfb /usr/share/tqt3/bin/qvfb
+/usr/bin/maketqpf /usr/share/tqt3/bin/maketqpf
+/usr/bin/tqvfb /usr/share/tqt3/bin/tqvfb