summaryrefslogtreecommitdiffstats
path: root/debian/lenny
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2013-10-02 20:22:28 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2013-10-02 20:22:28 +0200
commitcc3858bd8844988a5c49afb168be806168bea7e0 (patch)
tree12bbf83a9826e9daf9259c0b7d8feada197d8751 /debian/lenny
parent8af8d5c2c458ec76eca7074bed52ea49e73b477c (diff)
parent47864a912b26acfd0a5c4c0a8be6bfd8df892dd8 (diff)
downloadtde-packaging-cc3858bd8844988a5c49afb168be806168bea7e0.tar.gz
tde-packaging-cc3858bd8844988a5c49afb168be806168bea7e0.zip
RPM Packaging: updates
Diffstat (limited to 'debian/lenny')
-rw-r--r--debian/lenny/applications/filelight-l10n/debian/control4
-rw-r--r--debian/lenny/applications/kvpnc/debian/patches/13_add_kuser_issuperuser.diff12
-rw-r--r--debian/lenny/applications/kvpnc/debian/patches/series2
-rwxr-xr-xdebian/lenny/tdelibs/debian/rules35
-rwxr-xr-xdebian/lenny/tdelibs/debian/tdecmshell6
5 files changed, 45 insertions, 14 deletions
diff --git a/debian/lenny/applications/filelight-l10n/debian/control b/debian/lenny/applications/filelight-l10n/debian/control
index 4b3dc34e3..404650732 100644
--- a/debian/lenny/applications/filelight-l10n/debian/control
+++ b/debian/lenny/applications/filelight-l10n/debian/control
@@ -8,7 +8,7 @@ Standards-Version: 3.8.4
Homepage: http://www.methylblue.com/filelight/
Package: filelight-l10n-trinity
-Architecture: any
+Architecture: all
Depends: ${shlibs:Depends} , filelight-trinity
Replaces: filelight-l10n-trinity (<< 4:14.0.0~)
Breaks: filelight-l10n-trinity (<< 4:14.0.0~)
@@ -17,5 +17,5 @@ Description: Localization (l10n) for Filelight, disk space usage tool [Trinity]
Filelight, Filelight allows you to understand your disk usage by graphically
representing your filesystem as a set of concentric, segmented rings.
.
- See the 'filelight' package description for more information.
+ See the 'filelight-trinity' package description for more information.
diff --git a/debian/lenny/applications/kvpnc/debian/patches/13_add_kuser_issuperuser.diff b/debian/lenny/applications/kvpnc/debian/patches/13_add_kuser_issuperuser.diff
index 826d4e236..0729793b7 100644
--- a/debian/lenny/applications/kvpnc/debian/patches/13_add_kuser_issuperuser.diff
+++ b/debian/lenny/applications/kvpnc/debian/patches/13_add_kuser_issuperuser.diff
@@ -14,16 +14,16 @@ index 7c45fcf..b933832 100644
}
else
{
--// if (getenv("USER") != "root")
+-// if (getenv("USER") != TQString("root"))
-// {
-// KMessageBox::error( 0, I18N_NOOP( "Kvpnc must be started as root!" ) );
-// exit(0);
-// }
-+ if (getenv("USER") != "root")
-+ {
-+ KMessageBox::error( 0, I18N_NOOP( "Kvpnc must be started as root!" ) );
-+ exit(0);
-+ }
++ if (getenv("USER") != TQString("root"))
++ {
++ KMessageBox::error( 0, I18N_NOOP( "Kvpnc must be started as root!" ) );
++ exit(0);
++ }
TDECmdLineArgs *args = TDECmdLineArgs::parsedArgs();
diff --git a/debian/lenny/applications/kvpnc/debian/patches/series b/debian/lenny/applications/kvpnc/debian/patches/series
index 09040ada9..d29c3ca91 100644
--- a/debian/lenny/applications/kvpnc/debian/patches/series
+++ b/debian/lenny/applications/kvpnc/debian/patches/series
@@ -1,2 +1,2 @@
-10_su-to-root_usage.diff
+# 10_su-to-root_usage.diff
13_add_kuser_issuperuser.diff
diff --git a/debian/lenny/tdelibs/debian/rules b/debian/lenny/tdelibs/debian/rules
index 5ea30a3cc..1337de8b5 100755
--- a/debian/lenny/tdelibs/debian/rules
+++ b/debian/lenny/tdelibs/debian/rules
@@ -20,9 +20,38 @@ DEB_KDE_APIDOX := yes
version=Debian Package $(DEB_VERSION)
DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
-DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/tde" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" -DWITH_GCC_VISIBILITY="ON" -DWITH_LIBBFD="ON" \
--DWITH_LIBART="ON" -DWITH_LIBIDN="ON" -DWITH_TIFF="ON" -DWITH_JASPER="ON" -DWITH_OPENEXR="ON" -DWITH_AVAHI="ON" -DWITH_ASPELL="ON" -DWITH_HSPELL="ON" -DWITH_ELFICON="ON" -DWITH_TDEHWLIB_DAEMONS="ON" -DWITH_UPOWER="ON" -DWITH_UDISKS="ON" -DWITH_UDISKS2="ON" -DWITH_CONSOLEKIT="ON" -DWITH_NETWORK_MANAGER_BACKEND="ON" -DWITH_LZMA="ON" \
--DCMAKE_BUILD_TYPE=RelWithDebInfo
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DLIB_SUFFIX="" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" \
+ -DCMAKE_INCLUDE_PATH="/opt/trinity/include" \
+ -DAUTODETECT_QT_DIRS="ON" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DBUILD_ALL="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DWITH_GCC_VISIBILITY="ON" \
+ -DWITH_LIBBFD="ON" \
+ -DWITH_LIBART="ON" \
+ -DWITH_LIBIDN="ON" \
+ -DWITH_TIFF="ON" \
+ -DWITH_JASPER="ON" \
+ -DWITH_OPENEXR="ON" \
+ -DWITH_AVAHI="ON" \
+ -DWITH_ASPELL="ON" \
+ -DWITH_HSPELL="ON" \
+ -DWITH_ELFICON="ON" \
+ -DWITH_TDEHWLIB_DAEMONS="ON" \
+ -DWITH_UPOWER="ON" \
+ -DWITH_UDISKS="ON" \
+ -DWITH_UDISKS2="ON" \
+ -DWITH_CONSOLEKIT="ON" \
+ -DWITH_NETWORK_MANAGER_BACKEND="ON" \
+ -DWITH_LZMA="ON" \
+ -DWITH_XRANDR="ON" \
+ -DWITH_XCOMPOSITE="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
# never build in parallel, regardless of DEB_BUILD_OPTIONS.
diff --git a/debian/lenny/tdelibs/debian/tdecmshell b/debian/lenny/tdelibs/debian/tdecmshell
index 4e24cd356..64dea7e87 100755
--- a/debian/lenny/tdelibs/debian/tdecmshell
+++ b/debian/lenny/tdelibs/debian/tdecmshell
@@ -1,4 +1,6 @@
#!/bin/sh
-export TDEDIRS=/usr/:/opt/trinity/
-/opt/trinity/bin/tdecmshell.real $1 $2 $3 $4 $5 $6 $7 $8
+export XDG_CONFIG_DIRS=/opt/trinity/etc/xdg:/etc/xdg
+export XDG_DATA_DIRS=/opt/trinity/share:/usr/share
+
+${0}.real "$@"