summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/libraries/kipi-plugins/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
commit0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6 (patch)
treec0d0d652fef20159e78fa20b2567661bd7db8e41 /debian/squeeze/libraries/kipi-plugins/debian/rules
parent6b027437fd51e7874aaffed9e395ddf7913c3ab4 (diff)
downloadtde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.tar.gz
tde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.zip
Add initial Debian Lenny/Squeeze packaging as well as symlink Lucid to Maverick
Diffstat (limited to 'debian/squeeze/libraries/kipi-plugins/debian/rules')
-rwxr-xr-xdebian/squeeze/libraries/kipi-plugins/debian/rules46
1 files changed, 46 insertions, 0 deletions
diff --git a/debian/squeeze/libraries/kipi-plugins/debian/rules b/debian/squeeze/libraries/kipi-plugins/debian/rules
new file mode 100755
index 000000000..ec3d9a4a3
--- /dev/null
+++ b/debian/squeeze/libraries/kipi-plugins/debian/rules
@@ -0,0 +1,46 @@
+#!/usr/bin/make -f
+
+FILENAME = $(DEB_SOURCE_PACKAGE)_$(DEB_UPSTREAM_VERSION).orig.tar.gz
+UPFILENAME = $(DEB_SOURCE_PACKAGE)-$(DEB_UPSTREAM_VERSION).tar.bz2
+URL = http://heanet.dl.sourceforge.net/kipi/$(UPFILENAME)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--as-needed"
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+
+clean ::
+ rm -f po/*/*.gmo
+
+get-orig-source-dpatch:
+ @@dh_testdir
+ @@[ -d ../tarballs/. ]||mkdir -p ../tarballs
+ @@dpatch-get-origtargz ../tarballs
+
+get-orig-source:
+ @@dh_testdir
+ @@[ -d ../tarballs/. ]||mkdir -p ../tarballs
+ @@echo Downloading $(UPFILENAME) from $(URL) ...
+ @@wget -N -nv -T10 -t3 -O ../tarballs/$(UPFILENAME) $(URL)
+ @@echo Converting $(UPFILENAME) to $(FILENAME)
+ @@bzcat ../tarballs/$(UPFILENAME) | gzip -9 > ../tarballs/$(FILENAME)
+
+print-version:
+ @@echo DEB_SOURCE_PACKAGE: $(DEB_SOURCE_PACKAGE)
+ @@echo DEB_VERSION: $(DEB_VERSION)
+ @@echo DEB_NO_EPOCH_VERSION: $(DEB_NOEPOCH_VERSION)
+ @@echo DEB_UPSTREAM_VERSION: $(DEB_UPSTREAM_VERSION)
+ @@echo FILENAME: $(FILENAME)
+ @@echo URL: $(URL)
+