summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/tdegames/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-03-14 23:19:39 +0100
committerSlávek Banko <slavek.banko@axis.cz>2016-03-14 23:19:39 +0100
commit6c9a00a16267e6e069715b5ca7d87f2f4c470c4f (patch)
treea372039cb43d16aaf31cb0a539ecf6488152b7e9 /debian/squeeze/tdegames/debian/rules
parentc81710673fa72eae1f639cb94fd8c9ab1df69a26 (diff)
downloadtde-packaging-6c9a00a16267e6e069715b5ca7d87f2f4c470c4f.tar.gz
tde-packaging-6c9a00a16267e6e069715b5ca7d87f2f4c470c4f.zip
Switch tdegames to cmake on Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/squeeze/tdegames/debian/rules')
-rwxr-xr-xdebian/squeeze/tdegames/debian/rules14
1 files changed, 13 insertions, 1 deletions
diff --git a/debian/squeeze/tdegames/debian/rules b/debian/squeeze/tdegames/debian/rules
index 995e94c46..c49a0c0c4 100755
--- a/debian/squeeze/tdegames/debian/rules
+++ b/debian/squeeze/tdegames/debian/rules
@@ -1,13 +1,14 @@
#! /usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-qt-kde.mk
#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
include /usr/share/cdbs/1/rules/utils.mk
export kde_bindir = /opt/trinity/games
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
@@ -18,6 +19,17 @@ DEB_KDE_APIDOX := yes
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DBIN_INSTALL_DIR="/opt/trinity/games" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON"
+
DEB_DH_INSTALL_SOURCEDIR := $(DEB_DESTDIR)
DEB_INSTALL_DOCS_ALL :=