summaryrefslogtreecommitdiffstats
path: root/debian/wheezy/tdeadmin/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:13:23 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:13:23 -0500
commit05a59ddb0228494ba27bacbe7d391f06725b0689 (patch)
tree7c028104ac86c3b1e43ea3584528939bd8802426 /debian/wheezy/tdeadmin/debian/rules
parenta3210d42cfc1a2eb722dd85b0ddac0a2177f26ab (diff)
downloadtde-packaging-05a59ddb0228494ba27bacbe7d391f06725b0689.tar.gz
tde-packaging-05a59ddb0228494ba27bacbe7d391f06725b0689.zip
Split wheezy off of squeeze
Diffstat (limited to 'debian/wheezy/tdeadmin/debian/rules')
-rwxr-xr-xdebian/wheezy/tdeadmin/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/wheezy/tdeadmin/debian/rules b/debian/wheezy/tdeadmin/debian/rules
new file mode 100755
index 000000000..9c9ccadda
--- /dev/null
+++ b/debian/wheezy/tdeadmin/debian/rules
@@ -0,0 +1,19 @@
+#! /usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_DH_STRIP_ARGS := --dbg-package=tdeadmin-trinity-dbg
+
+DEB_CONFIGURE_EXTRA_FLAGS := \
+ --without-rpm --with-pam=kde --with-shadow --with-nis \
+ --with-private-groups --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib