summaryrefslogtreecommitdiffstats
path: root/dilos/tdepim/debian/patches
diff options
context:
space:
mode:
authorDenis Kozadaev <denis@dilos.org>2020-01-30 22:13:12 +0300
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-02 23:55:00 +0000
commitaaa680c41f65f2ac24364a0b4307b5aef00c0368 (patch)
treead36f4fb1c86fe6fffa1f3c5004c3e907e7f5a76 /dilos/tdepim/debian/patches
parent59e9776ac2de4f5006b9a16ef7da0dd21fbd9ccc (diff)
downloadtde-packaging-aaa680c41f65f2ac24364a0b4307b5aef00c0368.tar.gz
tde-packaging-aaa680c41f65f2ac24364a0b4307b5aef00c0368.zip
DilOS: tdepim build pack
Signed-off-by: Denis Kozadaev <denis@dilos.org>
Diffstat (limited to 'dilos/tdepim/debian/patches')
-rw-r--r--dilos/tdepim/debian/patches/dilos.patch39
-rw-r--r--dilos/tdepim/debian/patches/series1
2 files changed, 40 insertions, 0 deletions
diff --git a/dilos/tdepim/debian/patches/dilos.patch b/dilos/tdepim/debian/patches/dilos.patch
new file mode 100644
index 000000000..f8affdd33
--- /dev/null
+++ b/dilos/tdepim/debian/patches/dilos.patch
@@ -0,0 +1,39 @@
+Index: tdepim/cmake/modules/TDEMacros.cmake
+===================================================================
+--- tdepim.orig/cmake/modules/TDEMacros.cmake
++++ tdepim/cmake/modules/TDEMacros.cmake
+@@ -833,7 +833,7 @@ macro( tde_add_library _arg_target )
+
+ # set embedded archives
+ if( _embed )
+- list( INSERT _link 0 -Wl,-whole-archive ${_embed} -Wl,-no-whole-archive )
++ list( INSERT _link 0 -Wl,-zallextract ${_embed} -Wl,-zdefaultextract )
+ endif( _embed )
+
+ # set link libraries
+Index: tdepim/mimelib/CMakeLists.txt
+===================================================================
+--- tdepim.orig/mimelib/CMakeLists.txt
++++ tdepim/mimelib/CMakeLists.txt
+@@ -43,7 +43,7 @@ tde_add_library( mimelib SHARED
+ dwstring.cpp text.cpp token.cpp uuencode.cpp
+ binhex.cpp
+ VERSION 1.0.1
+- LINK ${TQT_LIBRARIES} ${TDE_LIB_DIR}/libtdefakes_pic.a
++ LINK ${TQT_LIBRARIES} ${TDE_LIB_DIR}/libtdefakes_pic.a socket nsl
+ DESTINATION ${LIB_INSTALL_DIR}
+ )
+
+Index: tdepim/kmail/kmfoldermbox.cpp
+===================================================================
+--- tdepim.orig/kmail/kmfoldermbox.cpp
++++ tdepim/kmail/kmfoldermbox.cpp
+@@ -46,7 +46,7 @@
+ #include <ctype.h>
+ #include <unistd.h>
+
+-#ifdef HAVE_FCNTL_H
++#if defined(HAVE_FCNTL_H) || defined(__dilos__)
+ #include <fcntl.h>
+ #endif
+
diff --git a/dilos/tdepim/debian/patches/series b/dilos/tdepim/debian/patches/series
new file mode 100644
index 000000000..c77ae3ebe
--- /dev/null
+++ b/dilos/tdepim/debian/patches/series
@@ -0,0 +1 @@
+dilos.patch