summaryrefslogtreecommitdiffstats
path: root/gentoo/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild')
-rw-r--r--gentoo/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/gentoo/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild b/gentoo/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
new file mode 100644
index 000000000..a568e11b4
--- /dev/null
+++ b/gentoo/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="a LGPL version of libart"
+HOMEPAGE="http://www.levien.com/libart"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig"
+
+# The provided tests are interactive only
+RESTRICT="test"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-static"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix crosscompiling, bug #185684
+ rm "${S}"/art_config.h
+ # NOTE patch is removed automake should handle it
+
+ # Do not build tests if not required
+ epatch "$FILESDIR/0001-gentoo-do-not-build-tests-if-not-required.patch"
+
+ # apply TDE patches
+ epatch "$FILESDIR/0002-TDE-fix-a-number-of-problems.patch"
+ epatch "$FILESDIR/0003-TDE-Clean-up-debug-spew.patch"
+
+ # apply user-provided patches
+ epatch_user
+
+ AT_NOELIBTOOLIZE=yes eautoreconf
+}