summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kdelibs/files
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/kdelibs/files
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/trinity-base/kdelibs/files')
-rw-r--r--gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-OnlyShowIn-TDE.patch26
-rw-r--r--gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-bug-1161.patch16
-rw-r--r--gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-insane-kde4-variables.patch13
-rw-r--r--gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-no-xcomposite.patch44
-rw-r--r--gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-make-xcomposite-optional.patch28
-rw-r--r--gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.2-make-xcomposite-optional.patch29
6 files changed, 156 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-OnlyShowIn-TDE.patch b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-OnlyShowIn-TDE.patch
new file mode 100644
index 000000000..9d9187f8e
--- /dev/null
+++ b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-OnlyShowIn-TDE.patch
@@ -0,0 +1,26 @@
+diff --git a/kinit/autostart.cpp b/kinit/autostart.cpp
+index 48325f2..d4bdb7b 100644
+--- a/kinit/autostart.cpp
++++ b/kinit/autostart.cpp
+@@ -178,7 +178,7 @@ AutoStart::loadAutoStartList()
+
+ if (config.hasKey("OnlyShowIn"))
+ {
+- if ((!config.readListEntry("OnlyShowIn", ';').contains("TDE")) && (!config.readListEntry("OnlyShowIn", ';').contains("KDE")))
++ if (!config.readListEntry("OnlyShowIn", ';').contains("TDE"))
+ continue;
+ }
+ if (config.hasKey("NotShowIn"))
+diff --git a/kio/kio/kservicegroup.cpp b/kio/kio/kservicegroup.cpp
+index 6758ca1..18b402b 100644
+--- a/kio/kio/kservicegroup.cpp
++++ b/kio/kio/kservicegroup.cpp
+@@ -84,7 +84,7 @@ KServiceGroup::KServiceGroup( const TQString &configFile, const TQString & _relp
+ TQStringList tmpList;
+ if (config.hasKey("OnlyShowIn"))
+ {
+- if ((!config.readListEntry("OnlyShowIn", ';').contains("TDE")) && (!config.readListEntry("OnlyShowIn", ';').contains("KDE")))
++ if (!config.readListEntry("OnlyShowIn", ';').contains("TDE"))
+ d->m_bNoDisplay = true;
+ }
+ if (config.hasKey("NotShowIn"))
diff --git a/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-bug-1161.patch b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-bug-1161.patch
new file mode 100644
index 000000000..094708ccd
--- /dev/null
+++ b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-bug-1161.patch
@@ -0,0 +1,16 @@
+diff --git a/kdeui/ksharedpixmap.cpp b/kdeui/ksharedpixmap.cpp
+index 29c6702..64c54e1 100644
+--- a/kdeui/ksharedpixmap.cpp
++++ b/kdeui/ksharedpixmap.cpp
+@@ -160,9 +160,8 @@ bool KSharedPixmap::x11Event(XEvent *event)
+ void *drawable_id = (void *) pixmap_id;
+ Drawable pixmap = *(Drawable*) drawable_id;
+
+- Status status = XGetGeometry(qt_xdisplay(), pixmap, &root, &dummy, &dummy, &width, &height, &udummy, &udummy);
+-
+- if (status == BadDrawable)
++ if (!XGetGeometry(qt_xdisplay(), pixmap, &root, &dummy, &dummy,
++ &width, &height, &udummy, &udummy))
+ return false;
+
+ if (d->rect.isEmpty())
diff --git a/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-insane-kde4-variables.patch b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-insane-kde4-variables.patch
new file mode 100644
index 000000000..2247b898f
--- /dev/null
+++ b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-insane-kde4-variables.patch
@@ -0,0 +1,13 @@
+diff --git a/kio/kio/kservice.cpp b/kio/kio/kservice.cpp
+index 4964103..368fe9a 100644
+--- a/kio/kio/kservice.cpp
++++ b/kio/kio/kservice.cpp
+@@ -198,7 +198,7 @@ KService::init( KDesktopFile *config )
+
+ m_strExec = config->readPathEntry( "Exec" );
+ if (kde4application && !m_strExec.startsWith("/")) {
+- m_strExec = "KDEHOME=$HOME/.kde XDG_DATA_DIRS=/usr/share KDEDIRS=/usr/ XDG_CONFIG_DIRS=/etc/xdg/ PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:$PATH "+m_strExec;
++ m_strExec = "KDEHOME=$HOME/.kde4 XDG_DATA_DIRS=/usr/share KDEDIRS=/usr/ XDG_CONFIG_DIRS=/etc/xdg/ PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:$PATH "+m_strExec;
+ } else if (config->readBoolEntry("X-KDE-SubstituteUID")) {
+ int space = m_strExec.find(" ");
+ if (space==-1)
diff --git a/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-no-xcomposite.patch b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-no-xcomposite.patch
new file mode 100644
index 000000000..e359a6284
--- /dev/null
+++ b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-no-xcomposite.patch
@@ -0,0 +1,44 @@
+--- kdecore/kapplication.cpp.orig 2012-10-26 11:49:24.000000000 +0400
++++ kdecore/kapplication.cpp 2012-10-26 11:49:33.000000000 +0400
+@@ -186,7 +186,7 @@
+ static Atom kde_xdnd_drop;
+ #endif
+
+-#ifdef Q_WS_X11
++#if defined(Q_WS_X11) && defined(COMPOSITE)
+ static int composite_event, composite_error, composite_opcode;
+ static bool x11_composite_error_generated;
+ static int x11_error(Display *dpy, XErrorEvent *ev) {
+@@ -1981,7 +1981,7 @@
+ return false;
+ }
+
+-bool KApplication::detectCompositionManagerAvailable(bool force_available) {
++bool KApplication::detectCompositionManagerAvailable(bool force_available, bool /* available */) {
+ const char *home;
+ struct passwd *p;
+ p = getpwuid(getuid());
+@@ -2023,21 +2023,17 @@
+ return 0;
+ }
+
+-Qt::HANDLE KApplication::getX11RGBAVisual(char *display) {
++Qt::HANDLE KApplication::getX11RGBAVisual(Display *dpy) {
+ return 0;
+ }
+
+-Qt::HANDLE KApplication::getX11RGBAColormap(char *display) {
++Qt::HANDLE KApplication::getX11RGBAColormap(Display *dpy) {
+ return 0;
+ }
+
+ bool KApplication::isX11CompositionAvailable() {
+ return false;
+ }
+-
+-KApplication KApplication::KARGBApplication( bool allowStyles ) {
+- return KApplication::KApplication(allowStyles, true);
+-}
+ #endif
+
+ static bool kapp_block_user_input = false;
diff --git a/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-make-xcomposite-optional.patch b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-make-xcomposite-optional.patch
new file mode 100644
index 000000000..1b7e1c91a
--- /dev/null
+++ b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.1-make-xcomposite-optional.patch
@@ -0,0 +1,28 @@
+--- CMakeLists.txt.orig 2012-10-25 09:20:57.773606598 +0400
++++ CMakeLists.txt 2012-10-26 07:18:14.793762688 +0400
+@@ -81,5 +81,6 @@
+ OPTION( WITH_ASPELL "Enable aspell support" OFF )
+ OPTION( WITH_HSPELL "Enable hspell support" OFF )
++OPTION( WITH_XCOMPOSITE "Enable xcomposite support" ${WITH_ALL_OPTIONS} )
+
+
+ ##### set PKG_CONFIG_PATH #######################
+@@ -564,10 +565,14 @@
+
+ ##### check for xcomposite #########################
+
+-pkg_search_module( XCOMPOSITE xcomposite )
+-if( XCOMPOSITE_FOUND )
+- set( HAVE_XCOMPOSITE 1 )
+-endif( XCOMPOSITE_FOUND )
++if( WITH_XCOMPOSITE )
++ pkg_search_module( XCOMPOSITE xcomposite )
++ if( XCOMPOSITE_FOUND )
++ set( HAVE_XCOMPOSITE 1 )
++ else()
++ message(FATAL_ERROR "\nxcomposite support was requested, but xcomposite was not found on your system" )
++ endif( XCOMPOSITE_FOUND )
++endif( WITH_XCOMPOSITE )
+
+ ##### check for libxml-2.0 ######################
+
diff --git a/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.2-make-xcomposite-optional.patch b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.2-make-xcomposite-optional.patch
new file mode 100644
index 000000000..c635b0036
--- /dev/null
+++ b/gentoo/trinity-base/kdelibs/files/kdelibs-3.5.13.2-make-xcomposite-optional.patch
@@ -0,0 +1,29 @@
+--- CMakeLists.txt.orig 2013-05-09 23:16:28.000000000 +0400
++++ CMakeLists.txt 2013-06-28 04:17:31.677764189 +0400
+@@ -85,6 +85,7 @@
+
+ OPTION( WITH_ASPELL "Enable aspell support" ${WITH_ALL_OPTIONS} )
+ OPTION( WITH_HSPELL "Enable hspell support" ${WITH_ALL_OPTIONS} )
++OPTION( WITH_XCOMPOSITE "Enable xcomposite support" ${WITH_ALL_OPTIONS} )
+
+ set( KDE4_DEFAULT_HOME ".kde" CACHE PATH "KDE4 home directory passed as KDEHOME to kde4 applications" )
+
+@@ -588,10 +589,14 @@
+
+ ##### check for xcomposite #########################
+
+-pkg_search_module( XCOMPOSITE xcomposite )
+-if( XCOMPOSITE_FOUND )
+- set( HAVE_XCOMPOSITE 1 )
+-endif( XCOMPOSITE_FOUND )
++if( WITH_XCOMPOSITE )
++ pkg_search_module( XCOMPOSITE xcomposite )
++ if( XCOMPOSITE_FOUND )
++ set( HAVE_XCOMPOSITE 1 )
++ else()
++ message(FATAL_ERROR "\nxcomposite support was requested, but xcomposite was not found on your system" )
++ endif( XCOMPOSITE_FOUND )
++endif( WITH_XCOMPOSITE )
+
+ ##### check for libxml-2.0 ######################
+