summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kmilo/kmilo-3.5.13.2.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/kmilo/kmilo-3.5.13.2.ebuild
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/trinity-base/kmilo/kmilo-3.5.13.2.ebuild')
-rw-r--r--gentoo/trinity-base/kmilo/kmilo-3.5.13.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kmilo/kmilo-3.5.13.2.ebuild b/gentoo/trinity-base/kmilo/kmilo-3.5.13.2.ebuild
new file mode 100644
index 000000000..99b580f88
--- /dev/null
+++ b/gentoo/trinity-base/kmilo/kmilo-3.5.13.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdeutils"
+
+inherit trinity-meta
+
+DESCRIPTION="kded module supports some hardware input devices, such as special keys"
+KEYWORDS="~x86 ~amd64"
+IUSE="asus-laptop dell-laptop powerbook-laptop thinkpad-laptop vaio-laptop lm_sensors"
+
+DEPEND="powerbook-laptop? ( app-laptop/pbbuttonsd )"
+RDEPEND="${DEPEND}
+ lm_sensors? ( sys-apps/lm_sensors )"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with asus-laptop ASUS)
+ $(cmake-utils_use_with dell-laptop I8K)
+ $(cmake-utils_use_with powerbook-laptop POWERBOOK2)
+ $(cmake-utils_use_with thinkpad-laptop THINKPAD)
+ $(cmake-utils_use_with vaio-laptop VAIO)
+ $(cmake-utils_use_with lm_sensors SENSORS)
+ )
+
+ trinity-meta_src_configure
+}