summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild')
-rw-r--r--gentoo/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/gentoo/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild b/gentoo/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild
new file mode 100644
index 000000000..adf21c3fb
--- /dev/null
+++ b/gentoo/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdeaddons"
+
+inherit trinity-meta
+
+DESCRIPTION="Documentaion for tdeaddons-derived packages"
+KEYWORDS=""
+IUSE+=""
+RDEPEND="
+ >=trinity-base/khelpcenter-${PV}:${SLOT}"
+
+pkg_setup() {
+ # we should reduce MAKEOPTS -j parametr to no more than 4
+ local makeopts_j
+ makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
+ if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
+ export MAKEOPTS="${MAKEOPTS//"${makeopts_j}"/-j4}"
+
+ ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
+ ewarn "mode so it can chew it all. MAKEOPTS are reduced to \"$MAKEOPTS\"."
+ fi
+
+ trinity-meta_pkg_setup
+}