summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/twin/twin-9999.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/twin/twin-9999.ebuild
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/trinity-base/twin/twin-9999.ebuild')
-rw-r--r--gentoo/trinity-base/twin/twin-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gentoo/trinity-base/twin/twin-9999.ebuild b/gentoo/trinity-base/twin/twin-9999.ebuild
new file mode 100644
index 000000000..927a0e5ea
--- /dev/null
+++ b/gentoo/trinity-base/twin/twin-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta eutils
+
+DESCRIPTION="Trinity window manager"
+KEYWORDS=
+IUSE="xcomposite xrandr xinerama +libconfig +pcre opengl"
+
+DEPEND="x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-proto/xineramaproto )
+ xrandr? ( x11-libs/libXrandr )
+ libconfig? ( dev-libs/libconfig )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre[jit] )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with xcomposite XCOMPOSITE)
+ $(cmake-utils_use_with xcomposite XFIXES)
+ $(cmake-utils_use_with xcomposite XRENDER)
+ $(cmake-utils_use_with xrandr XRANDR)
+ $(cmake-utils_use_with libconfig LIBCONFIG)
+ $(cmake-utils_use_with pcre PCRE)
+ $(cmake-utils_use_with xinerama XINERAMA)
+ )
+
+ trinity-meta_src_configure
+}
+
+pkg_postinst() {
+ if ! use xcomposite; then
+ for flag in xrandr xinerama libconfig pcre opengl; do
+ use $flag && \
+ ewarn "USE=\"$flag\" is passed, but it doesn't change anything due to" && \
+ ewarn "$flag support in ${P} take effect only if composite is enabled."
+ done
+
+ fi
+}