summaryrefslogtreecommitdiffstats
path: root/redhat/applications/ksplash-engine-moodin/ksplash-engine-moodin.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2019-03-10 20:22:48 +0100
committerFrançois Andriot <albator78@libertysurf.fr>2019-03-10 20:26:35 +0100
commitd6f47b905ee995b58fcb8388f683971ce9a2c7ed (patch)
tree576c5cd7b487b1bfb07e70649d4f3fe6c9c461fd /redhat/applications/ksplash-engine-moodin/ksplash-engine-moodin.spec
parent75c851fb864c4eacac9b6f27b77186a5d7f4f48b (diff)
downloadtde-packaging-d6f47b905ee995b58fcb8388f683971ce9a2c7ed.tar.gz
tde-packaging-d6f47b905ee995b58fcb8388f683971ce9a2c7ed.zip
RPM: switch many packages to cmake
Diffstat (limited to 'redhat/applications/ksplash-engine-moodin/ksplash-engine-moodin.spec')
-rw-r--r--redhat/applications/ksplash-engine-moodin/ksplash-engine-moodin.spec167
1 files changed, 167 insertions, 0 deletions
diff --git a/redhat/applications/ksplash-engine-moodin/ksplash-engine-moodin.spec b/redhat/applications/ksplash-engine-moodin/ksplash-engine-moodin.spec
new file mode 100644
index 000000000..638377ecb
--- /dev/null
+++ b/redhat/applications/ksplash-engine-moodin/ksplash-engine-moodin.spec
@@ -0,0 +1,167 @@
+#
+# spec file for package ksplash-engine-moodin (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.0
+%endif
+%define tde_pkg ksplash-engine-moodin
+%define tde_prefix /opt/trinity
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_tdeappdir %{tde_datadir}/applications/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 0.4.2
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Fading splash screen engine for Trinity
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+BuildRequires: gettext
+
+BuildRequires: cmake >= 2.8
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+
+%description
+Heavily customizable engine for various types of themes.
+
+Features:
+* scale cache
+* fading images
+* use current icon set or custom images
+* unlimited Custom text labels
+* set fading delay and length
+* custom image arrangement
+* resolution independent themes
+
+This TDE splash screen engine is based upon Linspire's
+engine by Sean Meiners <Sean.Meiners@LinspireInc.com>
+
+Homepage: http://moodwrod.com
+
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
+
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
+ \
+ -DCMAKE_INSTALL_PREFIX="%{tde_prefix}" \
+ -DSHARE_INSTALL_PREFIX="%{tde_datadir}" \
+ -DLIB_INSTALL_DIR="%{tde_libdir}" \
+ \
+ -DWITH_ALL_OPTIONS=ON \
+ -DWITH_GCC_VISIBILITY=ON \
+ \
+ -DBUILD_ALL=ON \
+ -DBUILD_DOC=ON \
+ -DBUILD_TRANSLATIONS=ON \
+ ..
+
+%__make %{?_smp_mflags} || %__make
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot} -C build
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{tde_tdelibdir}/ksplashmoodin.la
+%{tde_tdelibdir}/ksplashmoodin.so
+%if "%{?tde_version}" == "14.1.0"
+%{tde_datadir}/apps/ksplash/Themes/Architecture/
+%endif
+%{tde_datadir}/apps/ksplash/Themes/FingerPrint/
+%{tde_datadir}/apps/ksplash/Themes/MoodinKDE/
+%{tde_datadir}/services/ksplashmoodin.desktop
+
+
+%changelog