summaryrefslogtreecommitdiffstats
path: root/redhat/core/tdebindings/tdebindings.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2023-04-11 17:18:24 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2023-04-11 17:18:24 +0200
commitd8a1512d34559be713c40bf1b60940213ccde29d (patch)
treefe8206d2acc4ca6def42897f5c225ad7d1dab4d6 /redhat/core/tdebindings/tdebindings.spec
parentc58c672b5a1d7cbd8f0294cd9251d754cb44db26 (diff)
downloadtde-packaging-d8a1512d34559be713c40bf1b60940213ccde29d.tar.gz
tde-packaging-d8a1512d34559be713c40bf1b60940213ccde29d.zip
RPM: more updates related to python3
Signed-off-by: François Andriot <albator78@libertysurf.fr>
Diffstat (limited to 'redhat/core/tdebindings/tdebindings.spec')
-rw-r--r--redhat/core/tdebindings/tdebindings.spec13
1 files changed, 11 insertions, 2 deletions
diff --git a/redhat/core/tdebindings/tdebindings.spec b/redhat/core/tdebindings/tdebindings.spec
index 34a6c8212..6a69b7d9c 100644
--- a/redhat/core/tdebindings/tdebindings.spec
+++ b/redhat/core/tdebindings/tdebindings.spec
@@ -170,7 +170,8 @@ BuildRequires: Mesa-libGLU-devel
# PYTHON support
%define with_python 1
-%global __python python3
+%global python python3
+%global __python %__python3
%global python_sitearch %{python3_sitearch}
%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
BuildRequires: %{python}
@@ -685,8 +686,12 @@ This package is part of the official TDE bindings module.
%defattr(-,root,root,-)
%{python_sitearch}/pcop.la
%{python_sitearch}/pcop.so
+%if 0%{?rhel} == 7 || 0%{?suse_version}
%{python_sitearch}/pydcop.py*
-%{python_sitearch}/__pycache__/*.pyc
+%{python_sitearch}/__pycache__/pydcop.*.pyc
+%else
+%pycached %{python_sitearch}/pydcop.py
+%endif
%endif
@@ -1132,6 +1137,10 @@ EXTRA_INCLUDES="/usr/include/ruby-%{rb20_ver}:/usr/include/ruby-%{rb20_ver}/%{_t
EXTRA_INCLUDES="/usr/include/ruby-%{rb_ver}:/usr/include/ruby-%{rb_ver}/%{_target}-gnu"
%endif
+if [ -d "/usr/include/python3.6m" ]; then
+ EXTRA_INCLUDES="/usr/include/python3.6m:${EXTRA_INCLUDES}"
+fi
+
# Warning: GCC visibility causes FTBFS [Bug #1285]
%configure \
--prefix=%{tde_prefix} \