summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kmplayer/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-04-06 11:55:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-04-06 11:55:52 +0200
commit0c9b73ed16a351dd9c35498251abd31a87031cea (patch)
tree1785eae4c95d23edeb12005ee6e9abd7014d2ef7 /ubuntu/_base/applications/kmplayer/debian/rules
parentb8bef521dd84a0a5cf733ffe25d7888937c9e50e (diff)
downloadtde-packaging-0c9b73ed16a351dd9c35498251abd31a87031cea.tar.gz
tde-packaging-0c9b73ed16a351dd9c35498251abd31a87031cea.zip
DEB kmplayer: Switch to cmake.
Enabled build of KOffice plugin. Enabled support for GStreamer and NPP. The man page has been moved to the main tree. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/kmplayer/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kmplayer/debian/rules50
1 files changed, 11 insertions, 39 deletions
diff --git a/ubuntu/_base/applications/kmplayer/debian/rules b/ubuntu/_base/applications/kmplayer/debian/rules
index a972956aa..18aa16b96 100755
--- a/ubuntu/_base/applications/kmplayer/debian/rules
+++ b/ubuntu/_base/applications/kmplayer/debian/rules
@@ -1,47 +1,19 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-_P=)
-GCC_VERSION := $(shell gcc --version | sed -n "/^gcc/s/^[^$(_P)]*$(_P) \(.\..\).*/\1/p")
-ifeq ($(GCC_VERSION),4.3)
- CXX = g++ -fpermissive
-endif
-
-DEB_CONFIGURE_EXTRA_FLAGS := --enable-maintainer-mode --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-DEB_DH_INSTALL_ARGS = --sourcedir=debian/tmp
-DEB_INSTALL_MANPAGES_kmplayer = kmplayer.1
-
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-build/kmplayer-trinity::
- docbook2x-man debian/kmplayer.1.docbook
-
-clean::
- rm -f kmplayer.1
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"