summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tde-systemsettings/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-08-08 22:05:53 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-08-08 22:05:53 +0200
commit9d01b57af3673cc0e594a74fe0c12a4d3d9a59a3 (patch)
treeec2352037cb94e60c6b917ead81dae1d9732ec89 /ubuntu/_base/applications/tde-systemsettings/debian/rules
parent46afc510e176f408377a5f60105b5b5630027cad (diff)
downloadtde-packaging-9d01b57af3673cc0e594a74fe0c12a4d3d9a59a3.tar.gz
tde-packaging-9d01b57af3673cc0e594a74fe0c12a4d3d9a59a3.zip
DEB tde-systemsettings: Switch to cmake.
The man page has been moved to the main tree. Removed tde-settings-laptops.directory because it seems more current in the main tree. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/tde-systemsettings/debian/rules')
-rwxr-xr-xubuntu/_base/applications/tde-systemsettings/debian/rules57
1 files changed, 11 insertions, 46 deletions
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/rules b/ubuntu/_base/applications/tde-systemsettings/debian/rules
index 14f491a3e..18aa16b96 100755
--- a/ubuntu/_base/applications/tde-systemsettings/debian/rules
+++ b/ubuntu/_base/applications/tde-systemsettings/debian/rules
@@ -1,54 +1,19 @@
#!/usr/bin/make -f
-cdbs_kde_enable_debug = --disable-debug
-
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-cleanbuilddir/tde-systemsettings-trinity::
- rm -f systemsettings.1
-
-build/tde-systemsettings-trinity::
- docbook2x-man debian/systemsettings.1.docbook
-
-install/tde-systemsettings-trinity::
- # Don't clash files, just Use the ones from kcontrol
- rm debian/tde-systemsettings-trinity/opt/trinity/share/desktop-directories/tde-settings-power.directory
- rm debian/tde-systemsettings-trinity/opt/trinity/share/desktop-directories/tde-settings-system.directory
- rm debian/tde-systemsettings-trinity/opt/trinity/share/applications/tde/kcmfontinst.desktop
- rm debian/tde-systemsettings-trinity/opt/trinity/share/applications/tde/laptop.desktop
- cp debian/tde-settings-laptops.directory debian/tde-systemsettings-trinity/opt/trinity/share/desktop-directories/
-
-DEB_INSTALL_MANPAGES_tde-systemsettings-trinity = systemsettings.1
-
-binary-install/tde-systemsettings-trinity::
- mv debian/tde-systemsettings-trinity/usr/share/man debian/tde-systemsettings-trinity/opt/trinity/share/
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"