summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tde-systemsettings/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:45:52 +0800
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:45:52 +0800
commiteb16e7c7281e182297581fa8d565561869c81bca (patch)
tree4edf3c2dcd2a70e76c9581f04fbeb7d2a729f8b6 /ubuntu/_base/applications/tde-systemsettings/debian/rules
parent2064c92d78e53c5753ccc22a2b83abfe120fa8cb (diff)
downloadtde-packaging-eb16e7c7281e182297581fa8d565561869c81bca.tar.gz
tde-packaging-eb16e7c7281e182297581fa8d565561869c81bca.zip
DEB: added cmake directive to create compilation database 'compile_commands.json' at build time.
This can be used to provide linting, autocompletion, hovering info, go-to-definition and in general other LSP functionality in development environments. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/tde-systemsettings/debian/rules')
-rwxr-xr-xubuntu/_base/applications/tde-systemsettings/debian/rules1
1 files changed, 1 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/rules b/ubuntu/_base/applications/tde-systemsettings/debian/rules
index 18aa16b96..905d63101 100755
--- a/ubuntu/_base/applications/tde-systemsettings/debian/rules
+++ b/ubuntu/_base/applications/tde-systemsettings/debian/rules
@@ -8,6 +8,7 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \
-DCONFIG_INSTALL_DIR="/etc/trinity" \
-DSYSCONF_INSTALL_DIR="/etc/trinity" \