summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kpilot/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-03 04:15:17 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-03 04:42:32 +0100
commit270be7c030c63c370af1df3e680b51628189c501 (patch)
tree65339ab4758ada480038dbb56875ccc3072935fc /ubuntu/maverick/applications/kpilot/debian/rules
parent2423883a54867dcbbc6056f017361f212a37d100 (diff)
downloadtde-packaging-270be7c030c63c370af1df3e680b51628189c501.tar.gz
tde-packaging-270be7c030c63c370af1df3e680b51628189c501.zip
DEB kpilot: Switch to cmake.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 67af8bb6b90637d6169bf9785b34b713ed6be476)
Diffstat (limited to 'ubuntu/maverick/applications/kpilot/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kpilot/debian/rules39
1 files changed, 13 insertions, 26 deletions
diff --git a/ubuntu/maverick/applications/kpilot/debian/rules b/ubuntu/maverick/applications/kpilot/debian/rules
index e466423d3..18b1c07e2 100755
--- a/ubuntu/maverick/applications/kpilot/debian/rules
+++ b/ubuntu/maverick/applications/kpilot/debian/rules
@@ -1,33 +1,20 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"