summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/mplayerthumbs/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-07-26 03:09:16 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-07-26 03:09:16 +0200
commitfee752ab2accf52c3a6c77574b7d8271a806257f (patch)
tree61ac978d6d2924546357fa247185e81d23130a46 /ubuntu/maverick/applications/mplayerthumbs/debian/rules
parent80f1a1caacd86c3342672723f86cf2ea31e3f255 (diff)
downloadtde-packaging-fee752ab2accf52c3a6c77574b7d8271a806257f.tar.gz
tde-packaging-fee752ab2accf52c3a6c77574b7d8271a806257f.zip
Fix mplayerthumbs packaging files for Debian and Ubuntu
Diffstat (limited to 'ubuntu/maverick/applications/mplayerthumbs/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/mplayerthumbs/debian/rules34
1 files changed, 23 insertions, 11 deletions
diff --git a/ubuntu/maverick/applications/mplayerthumbs/debian/rules b/ubuntu/maverick/applications/mplayerthumbs/debian/rules
index 35f68ee80..89ce8a2dd 100755
--- a/ubuntu/maverick/applications/mplayerthumbs/debian/rules
+++ b/ubuntu/maverick/applications/mplayerthumbs/debian/rules
@@ -1,20 +1,32 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/autotools.mk
+include debian/cdbs/kde.mk
-# Add here any variable or target overrides you need.
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-build-stamp:
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
dh_testdir
- /usr/bin/libtoolize -f
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
- cp -f /usr/share/misc/config.guess admin/config.guess
- cp -f /usr/share/misc/config.sub admin/config.sub
- $(MAKE) -f admin/Makefile.common
-
- QTDIR=/usr/share/tqt3 ./configure $(configkde) --disable-final
- $(MAKE)
- touch build-stamp
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap