summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tellico/debian
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2015-01-15 03:49:37 +0100
committerSlávek Banko <slavek.banko@axis.cz>2015-01-15 03:49:37 +0100
commit47dff09e22d601a9efe65b4e25b06d1d3a1f1926 (patch)
tree5be08ff36ed66d555d9de778d671c4832d1e10d7 /ubuntu/maverick/applications/tellico/debian
parent463fd82feef90aef17b16b5b028b4e0b6eb32e5e (diff)
downloadtde-packaging-47dff09e22d601a9efe65b4e25b06d1d3a1f1926.tar.gz
tde-packaging-47dff09e22d601a9efe65b4e25b06d1d3a1f1926.zip
Fix regeneration of automake build system on Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/maverick/applications/tellico/debian')
-rwxr-xr-xubuntu/maverick/applications/tellico/debian/rules40
1 files changed, 3 insertions, 37 deletions
diff --git a/ubuntu/maverick/applications/tellico/debian/rules b/ubuntu/maverick/applications/tellico/debian/rules
index 72778a1fd..118fb52ac 100755
--- a/ubuntu/maverick/applications/tellico/debian/rules
+++ b/ubuntu/maverick/applications/tellico/debian/rules
@@ -32,32 +32,7 @@ else
CXXFLAGS += -O2
endif
-apply-patches:
- #apply patches first
- QUILT_PATCHES="debian/patches" quilt push -a -v
-
- #regenerate the acinclude file with the "Debian" libtool
- cp -a /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
- cat admin/acinclude.m4.in admin/libtool.m4.in >acinclude.m4
-
- #this will update the config.{sub,guess} and ltmain.sh files
- libtoolize -c -f
-
- # then, autoreconf with some tde magic
- autoreconf -v -i
- perl -w admin/am_edit
-
-update-autoconf:
- cp -a /usr/share/misc/config.sub admin/
- cp -a /usr/share/misc/config.guess admin/
-
-svn-number:
- sed -e "s/svn[^-]*-/svn`svn info | \
- grep "^Revision" | \
- sed -e "s/Revision: //"`-/" debian/changelog > new_changelog
- mv new_changelog debian/changelog
-
-config.status: configure
+config.status:
dh_testdir
# this makes the file more recent than configure and avoid make calling
@@ -68,6 +43,8 @@ config.status: configure
! [ -f /usr/share/libtool/config/ltmain.sh ] || \
cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -p /usr/share/misc/config.sub admin/config.sub
+ cp -p /usr/share/misc/config.guess admin/config.guess
make -f admin/Makefile.common cvs
@@ -102,14 +79,6 @@ clean:
dh_testroot
rm -f build-stamp
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
-
# Add here commands to clean up after the build process.
[ ! -f Makefile ] || $(MAKE) distclean
rm -f libtool config.log
@@ -131,9 +100,6 @@ install: build
admin/mkinstalldirs debian/tmp/opt/trinity/share/icons/hicolor/scalable/mimetypes
install -c -p -m 644 -T icons/tellico_mime.svg debian/tmp/opt/trinity/share/icons/hicolor/scalable/mimetypes/application-x-tellico.svg
- # Remove dead symlink from French translation
- rm debian/tmp/opt/trinity/share/doc/tde/HTML/fr/tellico/common
-
# Build architecture-independent files here.
binary-indep: build install