summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/tdepowersave/debian/rules
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2013-10-09 21:25:19 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2013-10-09 21:25:19 +0200
commitbd0ff7568ce64694ae7b1a180c1cc3654f4e60a9 (patch)
tree6074483ea9db86f4e118bd3ee987b9f78f63f143 /ubuntu/precise/applications/tdepowersave/debian/rules
parent1b75a8a69eb58af5ed985debdf5020df147d1df5 (diff)
parent26882ca86584e3ceecc0104ddfbf4f9d118c8e04 (diff)
downloadtde-packaging-bd0ff7568ce64694ae7b1a180c1cc3654f4e60a9.tar.gz
tde-packaging-bd0ff7568ce64694ae7b1a180c1cc3654f4e60a9.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/precise/applications/tdepowersave/debian/rules')
-rwxr-xr-xubuntu/precise/applications/tdepowersave/debian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/ubuntu/precise/applications/tdepowersave/debian/rules b/ubuntu/precise/applications/tdepowersave/debian/rules
index f74a76605..a891b0150 100755
--- a/ubuntu/precise/applications/tdepowersave/debian/rules
+++ b/ubuntu/precise/applications/tdepowersave/debian/rules
@@ -1,5 +1,6 @@
#!/usr/bin/make -f
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/kde.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/rules/patchsys-quilt.mk
@@ -17,9 +18,20 @@ DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinit
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON"
+
post-patches:: debian/stamp-bootstrap
debian/stamp-bootstrap:
+ifndef _cdbs_class_cmake
! [ -f /usr/share/libtool/ltmain.sh ] || \
cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
! [ -f /usr/share/libtool/config/ltmain.sh ] || \
@@ -27,6 +39,7 @@ debian/stamp-bootstrap:
cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
make -f admin/Makefile.common cvs
+endif
touch debian/stamp-bootstrap
install/tdepowersave-trinity::