summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/dependencies/avahi-tqt/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:16:32 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:16:32 -0500
commit02dc85a95b228b7242b0d11ea35619faad96db03 (patch)
treee161ba877a0720bbdf7818bdec06eb239d8ad271 /ubuntu/precise/dependencies/avahi-tqt/debian/rules
parent6f2c7dc70e77d2f768d687838b6cc9f7632f609e (diff)
downloadtde-packaging-02dc85a95b228b7242b0d11ea35619faad96db03.tar.gz
tde-packaging-02dc85a95b228b7242b0d11ea35619faad96db03.zip
Split precise from maverick
Diffstat (limited to 'ubuntu/precise/dependencies/avahi-tqt/debian/rules')
-rwxr-xr-xubuntu/precise/dependencies/avahi-tqt/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/ubuntu/precise/dependencies/avahi-tqt/debian/rules b/ubuntu/precise/dependencies/avahi-tqt/debian/rules
new file mode 100755
index 000000000..c3ea0343f
--- /dev/null
+++ b/ubuntu/precise/dependencies/avahi-tqt/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+# Ensure at build time that the library has no dependencies on undefined
+# symbols, and speed up loading.
+export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,-z,defs -Wl,-O1
+
+override_dh_auto_configure:
+ ./autogen.sh
+ dh_auto_configure -- $(CONFFLAGS) \
+ --enable-compat-libdns_sd \
+ --disable-mono --disable-monodoc \
+ --disable-gtk3 \
+ --with-systemdsystemunitdir=/lib/systemd/system
+