summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/dependencies/avahi-tqt/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-12-08 19:08:13 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-12-08 19:08:13 +0100
commit04e0ce7bb9c8e5be9a13569a21255fb321fb184e (patch)
tree45327cc590d8b2bfd8d6d9cc68dd5c7658181547 /ubuntu/precise/dependencies/avahi-tqt/debian/rules
parent642fca92b2caa55310a21f0b219de877ecf7c7c7 (diff)
downloadtde-packaging-04e0ce7bb9c8e5be9a13569a21255fb321fb184e.tar.gz
tde-packaging-04e0ce7bb9c8e5be9a13569a21255fb321fb184e.zip
Switch avahi-tqt packaging to cdbs on Debian and Ubuntu
Diffstat (limited to 'ubuntu/precise/dependencies/avahi-tqt/debian/rules')
-rwxr-xr-xubuntu/precise/dependencies/avahi-tqt/debian/rules14
1 files changed, 9 insertions, 5 deletions
diff --git a/ubuntu/precise/dependencies/avahi-tqt/debian/rules b/ubuntu/precise/dependencies/avahi-tqt/debian/rules
index c3ea0343f..d4694a4bf 100755
--- a/ubuntu/precise/dependencies/avahi-tqt/debian/rules
+++ b/ubuntu/precise/dependencies/avahi-tqt/debian/rules
@@ -1,17 +1,21 @@
#!/usr/bin/make -f
-%:
- dh $@
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
# Ensure at build time that the library has no dependencies on undefined
# symbols, and speed up loading.
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,-z,defs -Wl,-O1
-override_dh_auto_configure:
- ./autogen.sh
- dh_auto_configure -- $(CONFFLAGS) \
+DEB_CONFIGURE_EXTRA_FLAGS += \
--enable-compat-libdns_sd \
--disable-mono --disable-monodoc \
--disable-gtk3 \
--with-systemdsystemunitdir=/lib/systemd/system
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ./autogen.sh
+ rm ./ChangeLog
+ touch debian/stamp-bootstrap