summaryrefslogtreecommitdiffstats
path: root/ubuntu/raring/tdeutils/debian/patches
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-28 14:13:18 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-28 14:13:18 -0500
commit4bc22e8b188aa26df8b1a23c39bb0f3c5b05b8b6 (patch)
treec6f53decaabed9678523a8bbd6a1000a9f3bf78f /ubuntu/raring/tdeutils/debian/patches
parent211d261d7778de1d9a773e7ec43a4e97b4bd7e57 (diff)
downloadtde-packaging-4bc22e8b188aa26df8b1a23c39bb0f3c5b05b8b6.tar.gz
tde-packaging-4bc22e8b188aa26df8b1a23c39bb0f3c5b05b8b6.zip
Split raring packaging into new directory due to defoma changes
Diffstat (limited to 'ubuntu/raring/tdeutils/debian/patches')
-rw-r--r--ubuntu/raring/tdeutils/debian/patches/01-klaptopdaemon-setuphandler.diff35
-rw-r--r--ubuntu/raring/tdeutils/debian/patches/common/04_am_maintainer_mode.diff11
-rw-r--r--ubuntu/raring/tdeutils/debian/patches/common/06_disable_no_undefined.diff18
-rw-r--r--ubuntu/raring/tdeutils/debian/patches/common/kubuntu_01_kdepot.diff26
4 files changed, 90 insertions, 0 deletions
diff --git a/ubuntu/raring/tdeutils/debian/patches/01-klaptopdaemon-setuphandler.diff b/ubuntu/raring/tdeutils/debian/patches/01-klaptopdaemon-setuphandler.diff
new file mode 100644
index 000000000..3837407f6
--- /dev/null
+++ b/ubuntu/raring/tdeutils/debian/patches/01-klaptopdaemon-setuphandler.diff
@@ -0,0 +1,35 @@
+diff --git a/klaptopdaemon/acpi.cpp b/klaptopdaemon/acpi.cpp
+index 4dfb247..cd8f4b0 100644
+--- a/klaptopdaemon/acpi.cpp
++++ b/klaptopdaemon/acpi.cpp
+@@ -178,7 +178,7 @@ void AcpiConfig::setupHelper()
+ proc << tdesu;
+ proc << "-u";
+ proc << "root";
+- proc << "chown root "+helper+"; chmod +s "+helper;
++ proc << "dpkg-statoverride --update --add root root 6755 "+helper;
+ proc.start(TDEProcess::Block); // run it sync so has_acpi below sees the results
+ }
+ } else {
+diff --git a/klaptopdaemon/apm.cpp b/klaptopdaemon/apm.cpp
+index 9de0c85..e348943 100644
+--- a/klaptopdaemon/apm.cpp
++++ b/klaptopdaemon/apm.cpp
+@@ -166,7 +166,7 @@ void ApmConfig::setupHelper()
+ proc << tdesu;
+ proc << "-u";
+ proc << "root";
+- proc << TQString("chown root ")+apm_name+TQString("; chmod +s ")+apm_name;
++ proc << TQString("dpkg-statoverride --update --add root root 6755 ")+apm_name;
+ proc.start(TDEProcess::Block); // run it sync so has_apm below sees the results
+ }
+ } else {
+@@ -200,7 +200,7 @@ void ApmConfig::setupHelper2() // we use the acpi helper to do software suspend
+ proc << tdesu;
+ proc << "-u";
+ proc << "root";
+- proc << "chown root "+helper+"; chmod +s "+helper;
++ proc << "dpkg-statoverride --update --add root root 6755 "+helper;
+ proc.start(TDEProcess::Block); // run it sync so has_acpi below sees the results
+ }
+ } else {
diff --git a/ubuntu/raring/tdeutils/debian/patches/common/04_am_maintainer_mode.diff b/ubuntu/raring/tdeutils/debian/patches/common/04_am_maintainer_mode.diff
new file mode 100644
index 000000000..391a80285
--- /dev/null
+++ b/ubuntu/raring/tdeutils/debian/patches/common/04_am_maintainer_mode.diff
@@ -0,0 +1,11 @@
+--- a/admin/configure.in.min
++++ b/admin/configure.in.min
+@@ -38,6 +38,8 @@
+ dnl Automake doc recommends to do this only here. (Janos)
+ AM_INIT_AUTOMAKE(@MODULENAME@, @VERSION@) dnl searches for some needed programs
+
++AM_MAINTAINER_MODE
++
+ KDE_SET_PREFIX
+
+ dnl generate the config header
diff --git a/ubuntu/raring/tdeutils/debian/patches/common/06_disable_no_undefined.diff b/ubuntu/raring/tdeutils/debian/patches/common/06_disable_no_undefined.diff
new file mode 100644
index 000000000..05c932c3c
--- /dev/null
+++ b/ubuntu/raring/tdeutils/debian/patches/common/06_disable_no_undefined.diff
@@ -0,0 +1,18 @@
+--- a/admin/acinclude.m4.in
++++ b/admin/acinclude.m4.in
+@@ -1689,15 +1689,6 @@
+ KDE_USE_CLOSURE_TRUE="#"
+ KDE_USE_CLOSURE_FALSE=""
+ KDE_NO_UNDEFINED=""
+- case $host in
+- *-*-linux-gnu)
+- KDE_CHECK_COMPILER_FLAG([Wl,--no-undefined],
+- [KDE_CHECK_COMPILER_FLAG([Wl,--allow-shlib-undefined],
+- [KDE_NO_UNDEFINED="-Wl,--no-undefined -Wl,--allow-shlib-undefined"],
+- [KDE_NO_UNDEFINED=""])],
+- [KDE_NO_UNDEFINED=""])
+- ;;
+- esac
+ fi
+ AC_SUBST(KDE_USE_CLOSURE_TRUE)
+ AC_SUBST(KDE_USE_CLOSURE_FALSE)
diff --git a/ubuntu/raring/tdeutils/debian/patches/common/kubuntu_01_kdepot.diff b/ubuntu/raring/tdeutils/debian/patches/common/kubuntu_01_kdepot.diff
new file mode 100644
index 000000000..20ad1b0b7
--- /dev/null
+++ b/ubuntu/raring/tdeutils/debian/patches/common/kubuntu_01_kdepot.diff
@@ -0,0 +1,26 @@
+--- kde/admin/cvs.sh 2005-11-26 02:42:02.000000000 +0000
++++ kde/admin/cvs.sh 2005-11-26 02:42:26.000000000 +0000
+@@ -537,6 +537,8 @@
+ if test -z "$PREPARETIPS"; then PREPARETIPS=preparetips ; fi
+ export EXTRACTRC PREPARETIPS
+
++kdepotpath=/opt/trinity/include/tde/kde.pot
++
+ for subdir in $dirs; do
+ test -z "$VERBOSE" || echo "Making messages in $subdir"
+ (cd $subdir
+@@ -554,10 +556,10 @@
+ fi
+ perl -e '$mes=0; while (<STDIN>) { next if (/^(if\s|else\s|endif)/); if (/^messages:/) { $mes=1; print $_; next; } if ($mes) { if (/$\\(XGETTEXT\)/ && / -o/) { s/ -o \$\(podir\)/ _translatorinfo.cpp -o \$\(podir\)/ } print $_; } else { print $_; } }' < Makefile.am | egrep -v '^include ' > _transMakefile
+
+- kdepotpath=${includedir:-`tde-config --expandvars --install include`}/kde.pot
+- if ! test -f $kdepotpath; then
+- kdepotpath=`tde-config --expandvars --prefix`/include/kde.pot
+- fi
++# kdepotpath=${includedir:-`tde-config --expandvars --install include`}/kde.pot
++# if ! test -f $kdepotpath; then
++# kdepotpath=`tde-config --expandvars --prefix`/include/kde.pot
++# fi
+
+ $MAKE -s -f _transMakefile podir=$podir EXTRACTRC="$EXTRACTRC" PREPARETIPS="$PREPARETIPS" srcdir=. \
+ XGETTEXT="${XGETTEXT:-xgettext} --foreign-user -C -ci18n -ki18n -ktr2i18n -kI18N_NOOP -kI18N_NOOP2 -kaliasLocale -x $kdepotpath" messages