summaryrefslogtreecommitdiffstats
path: root/arch/tde-base/tde-tdebindings/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-base/tde-tdebindings/PKGBUILD')
-rw-r--r--arch/tde-base/tde-tdebindings/PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/arch/tde-base/tde-tdebindings/PKGBUILD b/arch/tde-base/tde-tdebindings/PKGBUILD
index cd59a6156..a3473b299 100644
--- a/arch/tde-base/tde-tdebindings/PKGBUILD
+++ b/arch/tde-base/tde-tdebindings/PKGBUILD
@@ -8,18 +8,18 @@ _cat=core/
_kdemod="${_mod/tde/kde}"
pkgname="tde-${_mod}"
-pkgver=14.0.12
+pkgver=14.0.13
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
url="https//scm.trinitydesktop.org/scm/git/${_mod}"
license=('GPL')
groups=('tde-base')
pkgdesc="Trinity Desktop bindings"
depends=('tde-tdelibs')
-makedepends=('pkgconfig' 'autoconf' 'imake' 'python2' 'ruby' 'jdk-openjdk' 'gtk2')
+makedepends=('pkgconfig' 'autoconf' 'ruby' 'jdk-openjdk')
options=('staticlibs' 'libtool' '!strip')
source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/${_cat}${_mod}-trinity-${pkgver}.tar.xz")
-md5sums=('305423d327fe5b7ca3260932044fa51d')
+md5sums=('5ff91819a140210b4a946ef7384b7abb')
[ -n "$TDEDIR" ] || TDEDIR=/opt/trinity
[ -n "$QTDIR" ] || QTDIR=${TDEDIR}/tqt3
@@ -29,6 +29,8 @@ build() {
cd ${srcdir}/${pkgname#*-}-trinity-${pkgver}
msg "Copying system libtool files...."
+ cp -a /usr/share/libtool/build-aux/config.guess ./admin/
+ cp -a /usr/share/libtool/build-aux/config.sub ./admin/
cp /usr/share/aclocal/libtool.m4 ./admin/libtool.m4.in
cp /usr/share/libtool/build-aux/ltmain.sh ./admin/ltmain.sh
@@ -48,7 +50,8 @@ build() {
--with-java=/usr/lib/jvm/default \
--sysconfdir=${TDEDIR}/etc \
--localstatedir=/var \
- --enable-closure
+ --enable-closure \
+ DO_NOT_COMPILE='dcopc dcopperl kalyptus qtsharp xparts python'
msg "Building - ${pkgname}..."
make $NUMJOBS